Package Details: python-numba-git 0.60.0dev0.r51.g6b511bf6b-1

Git Clone URL: https://aur.archlinux.org/python-numba-git.git (read-only, click to copy)
Package Base: python-numba-git
Description: NumPy aware dynamic Python compiler using LLVM (Git version)
Upstream URL: https://github.com/numba/numba
Licenses: BSD
Conflicts: python-numba
Provides: python-numba
Submitter: bcb
Maintainer: bcb
Last Packager: bcb
Votes: 1
Popularity: 0.000000
First Submitted: 2021-12-13 23:00 (UTC)
Last Updated: 2024-02-27 14:49 (UTC)

Dependencies (17)

Required by (99)

Sources (1)

Latest Comments

bcb commented on 2023-02-28 20:02 (UTC)

Probably he wanted to write python-llvmlite>0.38.999 instead of python-llvmlite>0.39.999.

No, the current Git version requires llvmite 0.40 (currently not released so you need the Git version of llvmlite). That style of formatting allows any 0.40 pre-release to fill the requirements.

In general, you should only use python-numba-git with python-llvmlite-git. Using it with an older release of llvmlite is not supported by upstream and may cause issues.

If you build python-llvmlite-git as of the time of this comment, you get version 0.40.0dev0.r55.gdffe582-1 which meets the requirement. Remember that for Git packages the version reported on the AUR website may be out of date as the pkgver() function runs when you build it.

In any case, this package seems to be broken also because the prepare() function does not currently work because of the numpy 1.24 patch.

It works for me, both on my main machine and in a clean chroot. Can you provide more details of what is failing for you?

iyanmv commented on 2023-02-28 10:14 (UTC)

Probably he wanted to write python-llvmlite>0.38.999 instead of python-llvmlite>0.39.999. In any case, it's a weird thing to do. Why not simply, python-llvmlite>=0.39.0?

In any case, this package seems to be broken also because the prepare() function does not currently work because of the numpy 1.24 patch.

eduardolucioac commented on 2023-01-30 01:52 (UTC)

In response to the last comment ( eduardolucioac commented on 2023-01-27 13:21 (UTC) ).

I modified in the "PKGBUILD" the line...

depends=('python-llvmlite>0.39.999' 'python-numpy' 'python-setuptools')

... to...

depends=('python-llvmlite==0.39.1' 'python-numpy' 'python-setuptools')

... which is the version of python-llvmlite available in the Manjaro (KDE) repository.

NOTE: I don't know if the same situation is observed with Arch.

TKS! 😎

eduardolucioac commented on 2023-01-27 13:21 (UTC)

The package...

[...]
==> Missing dependencies:
   -> python-llvmlite>0.39.999
[...]

... is not available in "any" repository, only the python-llvmlite-0.39.1-1 version.

Any solution suggestions?

Tks! 🤗

petronny commented on 2022-08-13 03:44 (UTC)

@bcb You are right. Searching cython in https://numba.readthedocs.io/ shows that cython is optional to access some high level API.

I'll report that to python-numba which lists cython as a makedepend.

bcb commented on 2022-08-11 16:59 (UTC)

Hi @petronny,

As far as I can see, Cython is not needed to build numba:

  • There is no mention of it in setup.py

  • find . -name "*.pyi" and find . -name "*.pyx" and find . -name "*.pyd" return nothing, suggesting there are no Cython sources in the numba repository.

  • I can successfully build the package in a clean chroot without the cython package installed.

Is there some problem you have found which I am not aware of?

petronny commented on 2022-08-11 04:59 (UTC)

Please add cython to makedepends.