Package Details: python-omegaconf 2.2.2-1

Git Clone URL: https://aur.archlinux.org/python-omegaconf.git (read-only, click to copy)
Package Base: python-omegaconf
Description: Flexible Python configuration system
Upstream URL: https://github.com/omry/omegaconf
Licenses: BSD
Submitter: harwiltz
Maintainer: lmartinez-mirror
Last Packager: lmartinez-mirror
Votes: 0
Popularity: 0.000000
First Submitted: 2020-06-06 22:10 (UTC)
Last Updated: 2022-05-30 00:16 (UTC)

Dependencies (8)

Sources (1)

Latest Comments

lmartinez-mirror commented on 2022-07-03 05:33 (UTC)

Does it come with a vendored version of python-antlr? If so, I'll remove the listed one from dependencies.

4rozenwolves commented on 2022-06-14 03:38 (UTC)

The installed omegaconf uses ANTLR 4.9.3 inside its package to generate its things. But when run it uses antlr 4.10.1 from the arch package causing error.

4rozenwolves commented on 2022-05-20 06:04 (UTC)

When running import torch_geometric I received

File "/usr/lib/python3.10/site-packages/omegaconf/grammar/gen/OmegaConfGrammarLexer.py", line 254, in <module>
    class OmegaConfGrammarLexer(Lexer):
File "/usr/lib/python3.10/site-packages/omegaconf/grammar/gen/OmegaConfGrammarLexer.py", line 256, in OmegaConfGrammarLexer
    atn = ATNDeserializer().deserialize(serializedATN())
File "/usr/lib/python3.10/site-packages/antlr4/atn/ATNDeserializer.py", line 28, in deserialize
    self.checkVersion()
File "/usr/lib/python3.10/site-packages/antlr4/atn/ATNDeserializer.py", line 50, in checkVersion
    raise Exception("Could not deserialize ATN with version " + str(version) + " (expected " + str(SERIALIZED_VERSION) + ").")
Exception: Could not deserialize ATN with version  (expected 4).

4rozenwolves commented on 2022-05-13 08:21 (UTC)

There is error while running PYTHONPATH=../ make man.

Exception: Could not deserialize ATN with version  (expected 4).

make: *** [Makefile:20: man] Error 2

thgravo commented on 2021-11-08 08:15 (UTC)

===================================================== test session starts ======================================================
platform linux -- Python 3.9.7, pytest-6.2.5, py-1.10.0, pluggy-0.13.1
Using --randomly-seed=552230553
rootdir: /home//.cache/yay/python-omegaconf/src/omegaconf-2.1.1, configfile: pyproject.toml
plugins: flake8-1.0.7, anyio-3.3.4, cov-2.12.1, mock-3.6.1, localserver-0.5.0, flaky-3.7.0, randomly-3.9.0
collected 4712 items / 1 error / 4711 selected                                                                                 

============================================================ ERRORS ============================================================
_____________________________________ ERROR collecting tests/test_pydev_resolver_plugin.py _____________________________________
ImportError while importing test module '/home//.cache/yay/python-omegaconf/src/omegaconf-2.1.1/tests/test_pydev_resolver_plugin.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib/python3.9/importlib/__init__.py:127: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
tests/test_pydev_resolver_plugin.py:21: in <module>
    from pydevd_plugins.extensions.pydevd_plugin_omegaconf import (
pydevd_plugins/extensions/pydevd_plugin_omegaconf.py:6: in <module>
    from _pydevd_bundle.pydevd_extension_api import (  # type: ignore
E   ModuleNotFoundError: No module named '_pydevd_bundle'
=================================================== short test summary info ====================================================
ERROR tests/test_pydev_resolver_plugin.py
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Interrupted: 1 error during collection !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
======================================================= 1 error in 1.42s =======================================================
==> ERROR: A failure occurred in check().
    Aborting...
 -> error making: python-omegaconf

trougnouf commented on 2021-09-01 14:14 (UTC)

Both download and check fail, please update:

pkgname='python-omegaconf'
pkgver='2.1.1'
pkgrel=1
epoch=
pkgdesc='Flexible Python configuration system. The last one you will ever need.'
arch=('any')
url='https://github.com/omry/omegaconf'
license=('custom')
depends=('python>=3.6'
         'python-pyaml>=5.1'
         'python-typing_extensions'
         'python-pip'
         'python-wheel')
checkdepends=('python-pytest' 'python-pytest-mock')
provides=("$pkgname=$pkgver")
source=("$pkgname-$pkgver::https://github.com/omry/omegaconf/archive/refs/tags/v$pkgver.tar.gz")
md5sums=('7f963258dd40c2c97aa0732e4a03b7b7')

package() {
  cd "omegaconf-$pkgver"
  python setup.py install --root="$pkgdir"
  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}