Package Details: python-optax 0.2.3-1

Git Clone URL: https://aur.archlinux.org/python-optax.git (read-only, click to copy)
Package Base: python-optax
Description: A gradient processing and optimization library for JAX
Upstream URL: https://github.com/google-deepmind/optax
Keywords: deepmind dm jax optimizator
Licenses: Apache
Groups: jax
Submitter: daskol
Maintainer: daskol
Last Packager: daskol
Votes: 2
Popularity: 0.175877
First Submitted: 2022-12-20 23:11 (UTC)
Last Updated: 2024-07-10 20:32 (UTC)

Dependencies (10)

Sources (1)

Latest Comments

daskol commented on 2024-03-07 18:22 (UTC) (edited on 2024-03-08 06:36 (UTC) by daskol)

@mane.andrea Thank you for noticing the issue! Maintainers of optax made another release with the same tag but different commit! I've faced already the same kind of problem with other package from DeepMind (or it was Google?) and created the issue. From my experience, people in DeepMind often do senseless things (crazy versioning as an example).

Anyway, I've updated checksums and reported the issue to Optax developers.

mane.andrea commented on 2024-03-07 18:00 (UTC) (edited on 2024-03-07 18:00 (UTC) by mane.andrea)

Why do I get (v0.2.0-1)

$ sha256sum optax-0.2.0.tar.gz
e3509bcf9be8768e0f19427abee1c524e64062447c185341cb27d2c30892e9fa  optax-0.2.0.tar.gz

Did you checksum the wrong file or is there something wrong?

I tried to download it twice.

Henry-ZHR commented on 2023-07-26 02:18 (UTC)

Should add makedepends python-flit-core

carlosal1015 commented on 2023-03-30 17:51 (UTC)

The PKGBUILD must remove echo sentence to include contents in the tarball, otherwise will empty

$ tar -I zstd -xvf python-optax-0.1.4-2-x86_64.pkg.tar.zst 
.BUILDINFO
.MTREE
.PKGINFO