Package Details: python-or-tools 7.6-1

Git Clone URL: (read-only, click to copy)
Package Base: python-or-tools
Description: Google's Operations Research tools
Upstream URL:
Keywords: or-tools ortools
Licenses: Apache2
Submitter: dariost
Maintainer: purisame
Last Packager: purisame
Votes: 5
Popularity: 0.42
First Submitted: 2017-07-11 23:45
Last Updated: 2020-04-24 04:00

Latest Comments

purisame commented on 2020-04-24 04:00

FirefighterBlu3: looks like python-wheel was missing in makedepends, which I've now added.

In other news, I've updated to v7.6 which was released today.

FirefighterBlu3 commented on 2020-04-10 17:54

has breakage in build()

cp -R /tmp/pkgbuilder-995/python-or-tools/src/or-tools-7.5/dependencies/install/lib/libproto* temp_python3.8/ortools/ortools/.libs
cp -R /libabsl* temp_python3.8/ortools/ortools/.libs
cp: cannot stat '/libabsl*': No such file or directory
make: [makefiles/ pypi_archive] Error 1 (ignored)
cp -R dependencies/install/lib*/libCbc* temp_python3.8/ortools/ortools/.libs
cp -R dependencies/install/lib*/libCgl* temp_python3.8/ortools/ortools/.libs
cp -R dependencies/install/lib*/libClp* temp_python3.8/ortools/ortools/.libs
cp -R dependencies/install/lib*/libOsi* temp_python3.8/ortools/ortools/.libs
cp -R dependencies/install/lib*/libCoinUtils* temp_python3.8/ortools/ortools/.libs
cd temp_python3.8/ortools && "/usr/bin/python3.8" bdist_wheel
usage: [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: --help [cmd1 cmd2 ...]
   or: --help-commands
   or: cmd --help

error: invalid command 'bdist_wheel'
make: *** [makefiles/ pypi_archive] Error 1
==> ERROR: A failure occurred in build().

purisame commented on 2020-01-28 20:50

why don't naming it python-ortools ? like the pypi package ?

I took maintenance of the package after it was orphaned, but it might be related to the repo being called or-tools on GitHub. If there's a way to rename it easily let me know.

I've updated the package to v7.5.

mizux commented on 2020-01-28 14:36

why don't naming it python-ortools ? like the pypi package ?

purisame commented on 2019-11-14 19:54

Python 3.8 support will arrive with the next release.

purisame commented on 2019-09-18 21:17

  • Updated the package to build OR Tools 7.3
  • Now, you get the same installation you would get if you installed it with pip
  • Relaxed Python version requirements to Python >= 3.5. Python 2.7 is being sunset so I haven't added it
  • Added a dependency on python-protobuf since the wheel file specifies it

Zento commented on 2018-08-09 09:40

The version limitation of the python dependency seems to be wrong. According to the documentation, the requirement is Python >=3.6 or Python >= 2.7.


Otherwise, thanks for maintaining the package!

dric512 commented on 2018-05-10 13:29

During installation, I noticed that the following packages are required for installation: wget and lsb-release