Package Details: python-paho-mqtt 1.3.1-1

Git Clone URL: https://aur.archlinux.org/paho-mqtt.git (read-only)
Package Base: paho-mqtt
Description: Python client library for MQTT v3.1 and v3.1.1
Upstream URL: http://www.eclipse.org/paho/clients/python
Licenses: EPL
Submitter: dseg
Maintainer: dseg (SpotlightKid)
Last Packager: SpotlightKid
Votes: 10
Popularity: 0.062698
First Submitted: 2014-12-09 05:53
Last Updated: 2017-10-23 05:55

Latest Comments

jplatte commented on 2017-10-22 16:22

Can't build this package with only Python 3 installed..

dseg commented on 2016-10-21 06:36

@XenGi
Thanks for the patch. Updated.

XenGi commented on 2016-10-15 20:46

Updated PKGBUILD for 1.2 release:

# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>

_pkgname=paho.mqtt.python
pkgbase=paho-mqtt
pkgname=(python-$pkgbase python2-$pkgbase)
pkgver=1.2
pkgrel=1
url="http://www.eclipse.org/paho/clients/python"
license=('EPL')
arch=('any')
source=("https://github.com/eclipse/paho.mqtt.python/archive/v1.2.tar.gz")
md5sums=('713dc196d4714baa1c27a72152dabbc3')


prepare() {
cp -r $_pkgname-${pkgver} py2-$_pkgname-${pkgver}
}

build() {
cd $srcdir/$_pkgname-${pkgver}
python setup.py build

cd $srcdir/py2-$_pkgname-${pkgver}
python2 setup.py build
}

package_python-paho-mqtt() {
pkgdesc="Python client library for MQTT v3.1 and v3.1.1"
depends=('python')

cd $srcdir/$_pkgname-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
}

package_python2-paho-mqtt() {
pkgdesc="Python 2 client library for MQTT v3.1 and v3.1.1"
depends=('python2')

cd $srcdir/py2-$_pkgname-$pkgver
python2 setup.py install --root="$pkgdir" --optimize=1
}

dseg commented on 2015-10-23 08:26

I've just tried to update the package, which contains the change for merging of the packages (python2-paho-mqtt, python-paho-mqtt) but failed because the python2-paho-mqtt is already exists so could not updated.
I've requested the deletion of python2-paho-mqtt, will try later if the request will be accepted.

dseg commented on 2015-09-03 08:24

@SpotlightKid
Thanks you, I completely agree with your idea and want to rename this package soon.

SpotlightKid commented on 2015-08-28 14:41

1. Shouldn't this package be renamed to 'python-paho-mqtt'?

2. The license should be changed to 'EPL', since it is provided in /usr/share/licenses/common.

3. makedepends=('python3') is redundant.

4. IMHO the project URL should be http://www.eclipse.org/paho/clients/python/.

5. We can make a split package for Python 2/3.

Here's my PKGBUILD with the above improvements: http://pastebin.com/MXncHDzK