Package Details: python-pdfminer.six 20201018-1

Git Clone URL: https://aur.archlinux.org/python-pdfminer.six.git (read-only, click to copy)
Package Base: python-pdfminer.six
Description: PDF parser and analyzer for Python
Upstream URL: https://github.com/pdfminer/pdfminer.six
Licenses: MIT
Submitter: ishitatsuyuki
Maintainer: ishitatsuyuki
Last Packager: ishitatsuyuki
Votes: 8
Popularity: 0.169525
First Submitted: 2017-12-06 08:18
Last Updated: 2020-11-20 13:54

Latest Comments

1 2 Next › Last »

bimmlerd commented on 2020-11-19 16:39

Hi ishitatsuyuki

I'm working on packaging paper2remarkable, which transitively depends on this package through pdfplumber, which I'm also trying to package. I have a request: pdfplumber currently requires specifically version '20200517' of pdfminer.six. Therefore, I'd be grateful if you could package that. I've taken the liberty of attempting the upgrade: https://gist.github.com/bimmlerd/e308df664a32c6379a7cdc8e60170cab

However, that isn't the newest version, that would be 20201018. Again, I've taken the liberty of also providing a PKGBUILD for that version: https://gist.github.com/bimmlerd/2de5892a67d523cb63bf4fae3a3d6861

Thanks.

ishitatsuyuki commented on 2020-03-09 09:54

It seems that these permission errors originates from the upstream tarball, so you might to complain on their tracker.

misc commented on 2020-03-08 00:53

needs something like chmod -R 644 $pkgdir/usr/lib/python*/site-packages/pdfminer/cmap (they're 600)

ishitatsuyuki commented on 2019-05-06 01:57

The package is now Python 3 only. Sorry for the delay. Thanks @pigmonkey!

pigmonkey commented on 2019-04-30 16:12

I ripped the python2 and pkgbase stuff out of your PKGBUILD. It works fine for me and satisfies the dependency for ocymypdf.

https://gist.github.com/pigmonkey/ff5986fadb7f2489a355570fe9c39de5

ishitatsuyuki commented on 2019-04-30 05:16

I think making this package Python 3 only is the way to go, as nobody seems to have a dependency on the Python 2 version and Python 2 is getting faded out anyway.

It's currently not a priority for me though; I will happily accept contributed PKGBUILDs.

pigmonkey commented on 2019-04-30 01:55

This problem could be avoided if the python2 and python3 packages were split, instead of using the same pkgbase with the same set of dependencies. That way users who desire the python2 version could figure out how to handle python2-sortedcontainers themselves, and users who only want python3 could install the package normally.

trickyelf commented on 2019-04-26 22:12

Could this package be made python3 only to avoid the python2-sortedcontainers problem?

ishitatsuyuki commented on 2019-04-14 04:17

I'm aware that python2-sortedcontainers is removed from the official repository, but I don't plan to maintain an AUR version. You can wait for somebody to upload that, or grab the PKGBUILD out of the Arch Linux SVN, or simply just grab a package from the archive.

eathtespagheti commented on 2019-04-12 09:54

Hi, python2-sortedcontainers has been removed from the AUR, so now it's impossible to install pdfminer