Package Details: python-pikepdf 1.3.0-1

Git Clone URL: https://aur.archlinux.org/python-pikepdf.git (read-only)
Package Base: python-pikepdf
Description: Read and write PDFs with Python, powered by qpdf
Upstream URL: https://github.com/pikepdf/pikepdf
Licenses: MPL2
Submitter: fbrennan
Maintainer: fbrennan
Last Packager: fbrennan
Votes: 2
Popularity: 1.245309
First Submitted: 2018-08-14 07:44
Last Updated: 2019-05-19 13:37

Latest Comments

colinkeenan commented on 2018-11-27 01:17

You are missing a dependency (or make dependency) 'python-setuptools'

jbehmel commented on 2018-09-03 14:01

Hey, just one question: Why are You not using https://github.com/pikepdf/pikepdf/archive/v0.3.1.tar.gz directly?

Morganamilo commented on 2018-08-30 18:55

It should be written as pybind<3 pybind>=2.3.3. Although I'd question if there's even a need to use versioned depends.

jbarlow commented on 2018-08-20 22:16

As a heads up, I am temporarily vendoring pybind11's master branch since they haven't made a release to fix a serious problem with pybind11 in Python 3.7. I'm hoping this won't be permanently necessary, so it's best to keep pybind11 as explicit dependency.

That means though, that you won't see any build-time differences from tinkering with the settings for pybind11.

sachilles commented on 2018-08-18 13:01

I'm not sure if this is right, but if you check https://wiki.archlinux.org/index.php/PKGBUILD#Dependencies for the definition of multiple dependencies. Just to interchange the operators from 'pybind11<3,>=2.2.3' to 'pybind11>=2.2.3,<3' did not help. Since pybind11 is currently in version 2.2.3 available only I did just remove the restriction '<3'.

fbrennan commented on 2018-08-18 07:41

I'm sorry, why would that help? pybind11 is already less than version 3...I was able to build the package without any changes at all in the paste below.

sachilles commented on 2018-08-18 07:10

Thanks for your reply. After replacing makedepends=('pybind11<3,>=2.2.3') by makedepends=('pybind11>=2.2.3') everthing works fine.

fbrennan commented on 2018-08-17 15:50

Works fine for me. The package release number really does not matter for this. It just means the pybind11 package was updated twice while the upstream version was still 2.2.3.

https://paste.ubuntu.com/p/tNqYgwmFvx/

sachilles commented on 2018-08-17 14:51

Hi,

I can't build the package because of the dependency "pybind11<3,>=2.2.3". This package is available in version 2.2.3-2 only!? (Just check the link in the section dependecies.)