Package Details: python-pillow-simd 1:7.0.0.post3-3

Git Clone URL: https://aur.archlinux.org/python-pillow-simd.git (read-only, click to copy)
Package Base: python-pillow-simd
Description: Python Imaging Library (PIL) fork. Pillow fork for better image processing performance.
Upstream URL: https://github.com/uploadcare/pillow-simd
Licenses: custom
Conflicts: python-pillow
Provides: python-pillow=7.0.0.post3
Submitter: simon04
Maintainer: simon04
Last Packager: simon04
Votes: 10
Popularity: 0.022494
First Submitted: 2017-09-06 10:36
Last Updated: 2020-12-02 14:20

Required by (531)

Sources (1)

Pinned Comments

simon04 commented on 2019-05-02 18:20

The one user requests a downgrade from 6.0.0 to 5.3.0.post1, the other requests an upgrade from 5.3.0.post1 to 6.0.0 To break this tie, I'll consider https://pypi.org/project/Pillow-SIMD/ as reference for the latest version.

Latest Comments

rharish commented on 2020-12-02 10:35

@simon04: Arch updated python to 3.9. I changed _py3basever to 3.9m, and it's working for me. Here's the diff:

diff --git a/PKGBUILD b/PKGBUILD
index 98b1e47..688bab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@

 pkgname=python-pillow-simd
 pkgver=7.0.0.post3
-pkgrel=2
+pkgrel=3
 epoch=1
 _name=Pillow-SIMD
-_py3basever=3.8m
+_py3basever=3.9m
 pkgdesc="Python Imaging Library (PIL) fork. Pillow fork for better image processing performance."
 arch=('x86_64')
 url="https://github.com/uploadcare/pillow-simd"

sjuxax commented on 2020-02-10 02:32

_py3basever is hardcoded to 3.7m. This no longer works as Arch is on Python 3.8. Manually fixing the PKGBUILD locally resolves. Please update. :)

simon04 commented on 2019-06-18 19:27

@otaj: Thanks for the pointer. Update the package.

otaj commented on 2019-06-12 11:18

Please add pkgver to provides (https://wiki.archlinux.org/index.php/PKGBUILD#provides), otherwise pacman won't recognize it and is complaining when using as a replacement for python-pillow when the version is specified.

To illustrate the point

otaj@otaj-ntb: sudo pacman -U python-pillow-simd-1:5.3.0.post1-1-x86_64.pkg.tar.gz
loading packages...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing python-pillow-simd (1:5.3.0.post1-1) breaks dependency 'python-pillow>=4.3.0' required by python-scikit-image

sQVe commented on 2019-05-02 18:23

@simon04 I agree. This package should use the same version that's available from pip. Version 6.0.0 is broken for me.

simon04 commented on 2019-05-02 18:20

The one user requests a downgrade from 6.0.0 to 5.3.0.post1, the other requests an upgrade from 5.3.0.post1 to 6.0.0 To break this tie, I'll consider https://pypi.org/project/Pillow-SIMD/ as reference for the latest version.

simon04 commented on 2018-08-14 05:27

@LChris314: Done. Thanks for the reminder!

LChris314 commented on 2018-08-13 17:49

Please update _py3basever to 3.7m, thank you.