Package Details: python-pipx 0.15.1.3-1

Git Clone URL: https://aur.archlinux.org/python-pipx.git (read-only, click to copy)
Package Base: python-pipx
Description: Execute binaries from Python packages in isolated environments
Upstream URL: https://github.com/cs01/pipx/
Licenses: MIT
Submitter: pmav99
Maintainer: pmav99
Last Packager: pmav99
Votes: 5
Popularity: 0.94
First Submitted: 2018-12-23 15:23
Last Updated: 2020-02-15 11:27

Latest Comments

potatoe commented on 2020-02-15 16:57

Thanks for updating! Quick note for folks running into errors after updating, from https://pipxproject.github.io/pipx/changelog/ :

When upgrading to 0.15.0.0 or above from a pre-0.15.0.0 version, you must re-install all packages to take advantage of the new persistent pipx metadata files introduced in this release. [...] You can do this by running pipx reinstall-all or pipx uninstall-all, then reinstalling manually.

SpotlightKid commented on 2020-02-15 09:09

python-setuptools should be in depends, not makedepends. The pipx script imports pkg_resources (like any setuptools entry-point generated command line script does).

Also, argcomplete and userpath are definitely both required run-time dependencies and not optional. They are declared as install_requires in the setup.py, so the pipx entry-point command line script won't run without them and both packages are imported, so not having them installed would lead to an ImportError.

Lastly, anything other than lack of time holding up the package update? Upstream is at version 0.15.1.3 now.

pmav99 commented on 2019-10-17 06:56

@malathion, I think that that you should bring this question to the pipx bug tracker. Until now, both userpath and argcomplete are declared as required dependencies [1]. Moreover I don't think you can run pipx without having argcomplete installed [2].

malathion commented on 2019-10-16 23:50

Does userpath really need to be a required dependency? It looks like it should be optional at best. There are lots of ways to manipulate the PATH

raxod502 commented on 2019-05-19 13:56

This appears to be because when I installed the AUR package originally, I had a virtualenv activated for another project. I have no idea why that would break it, but deactivating the virtualenv and uninstalling/reinstalling fixed the problem.

Sorry for the spurious report.

pmav99 commented on 2019-05-19 07:39

I can't reproduce this. I also didn't make any changes in the packaging approach for this release. Did the previous version work? Or is this the first time you tried to install the package?

BTW, have you previously installed pipx in some other way (e.g. pip install --user)? The traceback you posted also implies that you are in a virtualenv or something

raxod502 commented on 2019-05-19 03:48

After installing version 0.13.1.1-1 of this package, I get the following:

% pipx                         
Traceback (most recent call last):
  File "/usr/bin/pipx", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/home/raxod502/.cache/pypoetry/virtualenvs/utunes-py3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3191, in <module>
    @_call_aside
  File "/home/raxod502/.cache/pypoetry/virtualenvs/utunes-py3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3175, in _call_aside
    f(*args, **kwargs)
  File "/home/raxod502/.cache/pypoetry/virtualenvs/utunes-py3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3204, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/home/raxod502/.cache/pypoetry/virtualenvs/utunes-py3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/home/raxod502/.cache/pypoetry/virtualenvs/utunes-py3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/home/raxod502/.cache/pypoetry/virtualenvs/utunes-py3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pipx==0.13.1.1' distribution was not found and is required by the application

It seems that there is a packaging error somewhere.