Package Details: python-poppler-qt5 0.24.2-2

Git Clone URL: https://aur.archlinux.org/python-poppler-qt5.git (read-only)
Package Base: python-poppler-qt5
Description: Python binding to libpoppler-qt5.
Upstream URL: https://github.com/wbsoft/python-poppler-qt5
Keywords: poppler python qt qt5
Licenses: LGPL
Conflicts: python-poppler-qt5
Provides: python-poppler-qt5
Submitter: venatux
Maintainer: venatux
Last Packager: venatux
Votes: 19
Popularity: 1.141708
First Submitted: 2016-02-07 14:04
Last Updated: 2017-01-31 11:29

Latest Comments

Uncleoilybag commented on 2018-05-09 13:04

When trying to install this I keep getting this error message:- cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++

(I need this for Frescobaldi music program)

contrebasse commented on 2017-02-20 22:19

$ which gcc
/opt/cuda/bin/gcc

I had a problem in my PATH, the directories were in a wrong order and cuda uses gcc5. Everything works now. Thanks a lot !

I just have this warning:
cc1plus: attention : command line option « -Wstrict-prototypes » is valid for C/ObjC but not for C++

venatux commented on 2017-02-20 22:02

@contrebasse Do you have an updated system? From your error it seems that you have gcc version 5.4.0, but the newest is 6.3.1. Also, check that your version of python-sip is 4.19.1.

contrebasse commented on 2017-02-20 20:00

The build fails for me. The full error message can be found here:
https://framabin.org/?8b1296b82a855444#tsjA+D2S1Uos9zVtAzJ1yNijMP7Oi8eM7H8tmU2lPIU=

But in short:

cc1plus: attention : command line option « -Wstrict-prototypes » is valid for C/ObjC but not for C++
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/c++/type_traits:35:0,
from /usr/include/qt/QtCore/qglobal.h:45,
from /usr/include/qt/QtCore/qmetatype.h:44,
from /usr/include/qt/QtCore/QMetaType:1,
from build/temp.linux-x86_64-3.6/sipAPIpopplerqt5.h:12,
from build/temp.linux-x86_64-3.6/sippopplerqt5cmodule.cpp:7:
/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/include/c++/bits/c++0x_warning.h:32:2: erreur : #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support \

venatux commented on 2017-01-30 19:34

Updated the package with a patch that fixes the build issue with sip 4.19.

JBD commented on 2017-01-30 10:08

I had the same issue as neurOnic (coming from a python-sip API change). The problem seems to be solved with this patch (to put in place of the package patch):
https://framadrop.org/r/rsETm0CGCu#vFKOH+n5kPamYk5o6P9LtSKnj0ojPpBntpOjoID68JM=

neur0nic commented on 2017-01-27 15:17

I have some issues compiling. Seems similar to the comment in python-poppler-qt4 0.25.0-1.

In file included from build/temp.linux-x86_64-3.6/sippopplerqt5QList0600QLinkedList0100QPointF.cpp:7:0:
types.sip: In Funktion »int convertTo_QList_0600QLinkedList_0100QPointF(PyObject*, void**, int*, PyObject*)«:
build/temp.linux-x86_64-3.6/sipAPIpopplerqt5.h:1760:67: Fehler: »sipWrapperType {aka struct _sipWrapperType}« has no member named »type«
#define sipReleaseInstance(p, wt, s) sipReleaseType((p), (wt)->type, (s))
^
types.sip:231:7: Anmerkung: bei Substitution des Makros »sipReleaseInstance«
sipReleaseInstance(t, sipClass_TYPE, state);
^~~~~~~~~~~~~~~~~~
build/temp.linux-x86_64-3.6/sipAPIpopplerqt5.h:1760:67: Fehler: »sipWrapperType {aka struct _sipWrapperType}« has no member named »type«
#define sipReleaseInstance(p, wt, s) sipReleaseType((p), (wt)->type, (s))
^
types.sip:236:5: Anmerkung: bei Substitution des Makros »sipReleaseInstance«
sipReleaseInstance(t, sipClass_TYPE, state);

mav commented on 2017-01-22 16:44

needs "pkg-config" as make-dependency