Package Details: python-praw-git 4.0.0b11.r1580.g074bbe1-1

Git Clone URL: (read-only)
Package Base: python-praw-git
Description: A python package that allows for simple access to reddit's API
Upstream URL:
Licenses: GPL3
Conflicts: python-praw
Provides: python-praw
Submitter: imapiekindaguy
Maintainer: shaggytwodope
Last Packager: shaggytwodope
Votes: 11
Popularity: 0.137883
First Submitted: 2014-07-18 02:32
Last Updated: 2016-07-25 22:36

Required by (5)

Sources (1)

Latest Comments

imapiekindaguy commented on 2016-04-10 18:54

As I no longer use Arch Linux (or this package) with any regularity, I am disowning the python-praw-git and python-update_checker-git packages.

@IncredibleLaser, feel free to adopt the package and make the change yourself, though I don't really know what you are talking about. python-setuptools is not listed as both a dependency and make-dependency in the PKGBUILD; it is only in makedepends, as it should be.

IncredibleLaser commented on 2016-04-10 09:26

Small remark: when you have a dependency on python, no need to specify it as a make dependency also - all dependencies will be installed before building anyway for linking etc. makedepends is for stuff that actually builds the package, in this case missing python-setuptools. Please change.

SquirrelUR commented on 2015-07-14 20:24


No problem! Glad I could help!

imapiekindaguy commented on 2015-07-14 20:13

@SquirrelUR That's odd, I've been building the package but forgetting to install it, so my PRAW bots have been running just fine. The python-decorator package is needed, though, so I've added it to the dependencies. Thank you for letting me know!

SquirrelUR commented on 2015-07-14 19:35

Thank you for updating the wrapper to the aur4!

I noticed that I needed an additional package not listed here called the python-decorator located in the community repository. You might want to look into that.

Reihar commented on 2015-07-13 17:23


imapiekindaguy commented on 2015-07-11 08:57

@shaggytwodope Absolutely. I've added the conflict with python-praw.

shaggytwodope commented on 2015-07-11 08:03

Could you add conflict with python-praw package.