Package Details: python-pre-commit 1.21.0-1

Git Clone URL: https://aur.archlinux.org/python-pre-commit.git (read-only, click to copy)
Package Base: python-pre-commit
Description: Python 3 client for pre-commit
Upstream URL: http://pre-commit.com/
Licenses: MIT
Submitter: shosca
Maintainer: runaz
Last Packager: runaz
Votes: 3
Popularity: 0.79
First Submitted: 2017-05-02 12:47
Last Updated: 2020-01-06 23:20

Latest Comments

acidrain42 commented on 2020-01-06 16:40

The dependencies should be in depends instead of makedepends.

kmarc commented on 2019-12-27 10:18

python2-aspy-yaml package is missing, thus this package cannot be built

Also python-pre-commit (so the python3 version of pre-commit) should not depend on python2 packages, right?

runaz commented on 2019-06-17 16:36

@binsquare, should be fixed

binsquare commented on 2019-06-17 02:51

1.16.1 package is failing md5sums check

Update:

Fixed, thank you for the work!

rolis commented on 2018-11-01 17:38

python-importlib-metadata dependency is required as of 1.12.0, https://github.com/pre-commit/pre-commit/blob/v1.12.0/setup.py#L43 Thx

simon04 commented on 2018-06-13 06:42

This package lacks the dependencies on python-cfgv and python-toml, see https://github.com/pre-commit/pre-commit/blob/v1.10.2/setup.py#L38-L48

finkregh commented on 2017-12-18 14:19

md5sum for v0.4.1: a4a6e40ec4c41a654b90526b5044b66d

ImNtReal commented on 2017-08-10 20:39

I added a package called python-identify that I think is required by this package.

evgfilim1 commented on 2017-05-11 16:22

Please add to dependencies 'python-virtualenv' and 'python-cached-property':

Traceback (most recent call last):
...
pkg_resources.DistributionNotFound: The 'virtualenv' distribution was not found and is required by pre-commit

Traceback (most recent call last):
...
pkg_resources.DistributionNotFound: The 'cached-property' distribution was not found and is required by pre-commit