Package Details: python-prompt_toolkit-2 2.0.7-3

Git Clone URL: https://aur.archlinux.org/python-prompt_toolkit-2.git (read-only)
Package Base: python-prompt_toolkit-2
Description: Library for building powerful interactive command line applications in Python
Upstream URL: https://github.com/jonathanslenders/python-prompt-toolkit
Licenses: BSD
Conflicts: python-prompt_toolkit
Provides: python-prompt_toolkit
Submitter: asm0dey
Maintainer: asm0dey
Last Packager: asm0dey
Votes: 3
Popularity: 0.076256
First Submitted: 2018-10-09 07:49
Last Updated: 2018-12-02 06:34

Dependencies (4)

Required by (26)

Sources (1)

Latest Comments

1 2 Next › Last »

asm0dey commented on 2018-12-02 06:39

@blueyed I've updated my package to provide python-prompt_toolkit, not python-prompt_toolkit-2, now you should be able to select what you need

asm0dey commented on 2018-11-29 13:55

@blueyed sorry, python-prompt_toolkit is still version 1 on manjaro, so I'm not ready to migrate from this package

blueyed commented on 2018-11-29 13:05

(It would be nice to get this sorted out for pgcli, which I am not upgrading since a while already due to this.)

blueyed commented on 2018-11-29 13:04

@asm0dey There is also python2-prompt_toolkit, if that is what you mean.

asm0dey commented on 2018-11-19 14:52

@blueyed is it available for both py2 and 3?

blueyed commented on 2018-11-19 12:55

community/python-prompt_toolkit has been updated to 2.0.7-1, so this package should not be needed anymore I guess?!

asm0dey commented on 2018-11-11 20:45

@kwrazi @qwivan I've built ipython-7 package, which works well with prompt_toolkit-2 well, so you can just replace ipython with ipython-7

kwrazi commented on 2018-11-10 12:55

The ipython packages available in the archlinux repository (6.5.0 and 5.8.0 for python2) are old. However the latest release, 7.1.1 supports prompt_toolkit >=2.0.0, <2.1.0.

pgcli (AUR) works with this version of prompt_toolkit.

There is currently a pull request (https://github.com/dbcli/mycli/pull/684) on the mycli git repository to make it work with prompt_tool >= 2.0.6.

asm0dey commented on 2018-11-10 09:30

@qwivan No, because python just doesn't work this way. For python they are conflicting versions of one library. The same for AUR consequently. But you can install ptpython for python3 (because it's interactive shell) and pgcli and mycli for python2 (because they're just applications and who cares which version of python do they use.

Of course you can address tis issue to @kwrazi, who is original maintainer of ptpython.

qwivan commented on 2018-11-10 08:37

ptpython is require prompt_toolkit 2, but ipython, mycli and pgcli are require prompt_toolkit 1. So, can we make them coexist?