Package Details: python-pycparser-git 20131228-1

Git Clone URL: https://aur.archlinux.org/python-pycparser-git.git (read-only)
Package Base: python-pycparser-git
Description: C parser and AST generator written in Python
Upstream URL: https://github.com/eliben/pycparser
Licenses: BSD
Conflicts: pycparser, python-pycparser, python-pycparser-hg
Submitter: xyproto
Maintainer: None
Last Packager: xyproto
Votes: 14
Popularity: 0.000000
First Submitted: 2013-06-24 19:49
Last Updated: 2015-06-10 12:56

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

justin8 commented on 2013-12-30 23:05

It wasn't at all, I only created it a few minutes before posting. I was trying to purge git packages from my systems where relevant stable branches exist :)

Cheers!

justin8 commented on 2013-12-30 23:05

It wasn't at all, I only created it a few minutes before posting. I was trying to purge git packages from my systems where relevant stable branches exist :)

xyproto commented on 2013-12-30 16:16

Thanks, justin8. A slip. Updated the package.

justin8 commented on 2013-12-30 07:59

This should be 'conflicts=' not 'replaces='. Otherwise having this in a local repo will always replace non-git versions with git versions. See: https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#Guidelines

Also number 6 here: https://wiki.archlinux.org/index.php/Arch_Packaging_Standards#Submitting_packages_to_the_AUR

justin8 commented on 2013-12-30 07:55

This should be 'conflicts=' not 'replaces='. Otherwise having this in a local repo will always replace non-git versions with git versions. See: https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#Guidelines

Also number 6 here: https://wiki.archlinux.org/index.php/Arch_Packaging_Standards#Submitting_packages_to_the_AUR

hells commented on 2013-06-24 16:59

Builds fine, I think it should have git as a dependency now though. Thanks again :)

hells commented on 2013-06-23 20:52

Thanks for the quick update xyproto! Also the Upstream URL should be changed to reflect the change. Including the project url in the PKGBUILD. Will test this out here later as I'm doing a new install.

G2P commented on 2013-06-23 17:45

You missed one field (the project url, nothing critical).

xyproto commented on 2013-06-23 17:33

Thanks, updated the package.

hells commented on 2013-06-23 15:18

https://github.com/eliben/pycparser.git is the url

hells commented on 2013-06-23 15:18

He moved his repo to git and I am not very good at writing a new pkgbuild sorry :( Flagged out of date though.

G2P commented on 2013-06-08 19:54

I had to fudge things a bit to test (manually rename to the old name to satisfy python-cffi), and it appears to work without problems. Thanks!

xyproto commented on 2013-06-08 18:39

Thanks, G2P. Updated the PKGBUILD and merged(+deleted) it to python-pycparser-hg. The files are generated in the prepare() function now. Please let me know if it works as expected.

G2P commented on 2013-06-07 13:53

The package is not out of date, sorry.
Those files should be prebuilt somehow.

G2P commented on 2013-06-07 13:31

You should upgrade to 2.9.1, because this one will dump lextab.py and yacctab.py files in any directory it runs.

xyproto commented on 2013-01-18 20:03

Deleting/merging into python-pycparser.

xyproto commented on 2013-01-01 18:44

Flagged as out of date for a year (+-6 days). Disowning.

lilydjwg commented on 2012-12-10 10:13

Hi there, I've made an updated PKGBUILD here:
http://hpaste.org/79038

It is version 2.07 because python-cffi says there is a bug in 2.08.

xyproto commented on 2012-04-11 18:26

Please depend on python-ply instead and resubmit as python-pycparser, then ask either me or the aur_general mailinglist to remove this package.

mathieu.clabaut commented on 2011-06-28 12:22

It would be nice to also install examples/ and utils/ in /usr/share/pycparser