Package Details: python-pyfai 2024.02-1

Git Clone URL: https://aur.archlinux.org/python-pyfai.git (read-only, click to copy)
Package Base: python-pyfai
Description: Fast Azimuthal Integration in Python.
Upstream URL: http://www.silx.org
Licenses: BSD, MIT, GPLv3
Submitter: blochl
Maintainer: blochl
Last Packager: blochl
Votes: 2
Popularity: 0.028974
First Submitted: 2017-01-03 22:25 (UTC)
Last Updated: 2024-02-17 16:22 (UTC)

Required by (1)

Sources (1)

Latest Comments

blochl commented on 2023-11-03 06:22 (UTC)

Thanks for the comment! python-silx added as an optdepend, without bumping pkgrel, as it has no effect on the package itself.

sam9032 commented on 2023-10-30 21:18 (UTC)

Thank you! Everything works fine now. fabio_viewer starts without a problem.

Perhaps it would be useful to add python-silx as an dependency or optional dependency? pyFAI-calib2 will only start if python-silx is installed.

blochl commented on 2023-10-30 09:13 (UTC) (edited on 2023-10-30 09:13 (UTC) by blochl)

Hi @sam9032!

Sorry - missed your comment before. Thanks for reporting!

Can you please try the new versions of the three packages (python-{fabio,silx,pyfai})?

I just tried them on a bare container, and they all seem to work.

sam9032 commented on 2023-10-24 12:38 (UTC)

Hi there,

I have a problem with the package. It says, fabio is missing but the python-fabio installation is fine.

Any idea what to try?

According to the installation procedure in the pyfai docs, the Installation method with python setup.py installis deprecated. Maybe there is a problem?

"Nota: The usage of “python setup.py install” is now deprecated. One should never use sudo pip as it is likely to interfer with the software installed with the system."

https://www.silx.org/doc/pyFAI/latest/operations/linux.html#installation-procedure-on-other-linux-distibution