Package Details: python-pyfits 3.5-1

Git Clone URL: https://aur.archlinux.org/python-pyfits.git (read-only, click to copy)
Package Base: python-pyfits
Description: A python language interface to FITS formatted data files
Upstream URL: http://www.stsci.edu/resources/software_hardware/pyfits
Licenses: BSD
Submitter: None
Maintainer: gypaetus
Last Packager: gypaetus
Votes: 18
Popularity: 0.000000
First Submitted: 2006-06-19 18:17
Last Updated: 2017-12-20 17:09

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

ressler commented on 2011-12-03 18:39

Bugfix update to 3.0.4.

ressler commented on 2011-10-03 19:56

Bug fix update to 3.0.2.

ressler commented on 2011-09-14 15:24

Bug fix update.

ressler commented on 2011-08-30 18:46

Updating to pyfits-3.0 which includes python3 support. At the risk of breaking packages that depend on python-pyfits, I have followed the naming conventions of numpy and scipy where e.g. python-numpy is the python3 version, and python2-numpy is for python2; same here. Unfortunately, AUR does not allow split packages in one PKGBUILD, so there is now a python-pyfits entry and a python2-pyfits entry.

This python3 version is only lightly tested since most of my day-to-day work still uses python2. Please let me know of any mistakes.

ressler commented on 2011-07-30 18:06

Forgot to increment the pkgrel variable - fixed.

ressler commented on 2011-07-30 18:05

Forgot to increment the pkgrel variable.

ressler commented on 2011-07-30 18:04

Changed dependency to python2-numpy

ressler commented on 2011-07-30 18:03

I was hoping that STScI would release their python3 compatible version soon. Then I could do everything at once. When they do, I'll change the PKGBUILD to do the python2/3 trick that things like numpy and scipy do. For now, I'll just do the python2-numpy dependency fix.

giniu commented on 2011-07-19 07:37

Yes, especially now that python3-numpy was finally renamed to python-numpy and python2-numpy no longer provides python-numpy.

mboquien commented on 2011-07-19 07:20

Hello. I think this package should depend on python2-numpy. Thanks.