Package Details: python-pyqt-qwt 1.02.02.20210915-1

Git Clone URL: https://aur.archlinux.org/python-pyqt-qwt.git (read-only, click to copy)
Package Base: python-pyqt-qwt
Description: Python PyQt wrapper for Qwt 6
Upstream URL: https://github.com/GauiStori/PyQt-Qwt
Licenses: LGPL, custom:qwt
Submitter: morgenstern
Maintainer: morgenstern
Last Packager: morgenstern
Votes: 1
Popularity: 0.000062
First Submitted: 2021-03-06 03:33 (UTC)
Last Updated: 2021-12-22 23:48 (UTC)

Latest Comments

gnaggnoyil commented on 2021-12-23 14:21 (UTC)

@morgenstern Thanks. Can confirm this is building now.

morgenstern commented on 2021-12-22 23:45 (UTC)

There is a pending pull request that compiles successfully. I have updated the PKGBUILD to build from this branch for now and have asked the developer to consider merging it soon.

morgenstern commented on 2021-12-18 00:30 (UTC)

Thanks for the report @gnaggnoyil. I am also getting multiple sip build errors, even when building from the latest commit in the master branch.

I have opened an issue upstream with the developer - will see what they come back with.

gnaggnoyil commented on 2021-12-17 11:35 (UTC)

I encountered the following error when building current version(1.02.02-2):

/home/gnaggnoyil/.cache/yay/python-pyqt-qwt/src/PyQt-Qwt-1.02.02/build/Qwt/sipQwtQwtCompassScaleDraw.cpp:234:71: 错误:对不完全的类型‘class QMap<double, QString>’的非法使用
  234 |             sipRes = new  ::QMap<double, ::QString>(sipCpp->labelMap());
      |                                                                       ^
In file included from /usr/include/qt/QtCore/qglobal.h:1295,
                 from /usr/include/qt/QtCore/qmetatype.h:45,
                 from /usr/include/qt/QtCore/QMetaType:1,
                 from sipAPIQwt.h:12,
                 from sipQwtQwtCompassScaleDraw.cpp:7:
/usr/include/qt/QtCore/qtypeinfo.h:240:29: 附注:declaration of ‘class QMap<double, QString>’
  240 | Q_DECLARE_MOVABLE_CONTAINER(QMap);
      |                             ^~~~
/usr/include/qt/QtCore/qtypeinfo.h:222:41: 附注:in definition of macro ‘Q_DECLARE_MOVABLE_CONTAINER’
  222 | template <typename K, typename V> class CONTAINER; \
      |                                         ^~~~~~~~~
make[1]: *** [Makefile:1670:sipQwtQwtCompassScaleDraw.o] 错误 1
make[1]: 离开目录“/home/gnaggnoyil/.cache/yay/python-pyqt-qwt/src/PyQt-Qwt-1.02.02/build/Qwt”
make: *** [Makefile:47:sub-Qwt-make_first-ordered] 错误 2
sip-build: 'make' failed returning 2
==> 错误: 在 build() 中发生一个错误。
    正在放弃...
 -> 生成时出错: python-pyqt-qwt

What could possibly go wrong?