Package Details: python-pyqtgraph 0.9.10-1

Git Clone URL: (read-only)
Package Base: python-pyqtgraph
Description: Scientific Graphics and GUI Library for Python
Upstream URL:
Licenses: MIT
Submitter: windel
Maintainer: windel
Last Packager: windel
Votes: 23
Popularity: 1.244814
First Submitted: 2013-12-04 21:14
Last Updated: 2016-02-20 09:07

Required by (4)

Sources (1)

Latest Comments

windel commented on 2016-02-20 09:08

Thanks minus! Fixed it!

minus commented on 2016-02-20 08:20

Please update the PKGBUILD to be compatible with pacman 5:
==> ERROR: license should be an array

goetzc commented on 2015-10-01 22:00

edward_81, I have just rebuild it without issues. Try building this package manually with makepkg to see if the error persists.

edward_81 commented on 2015-09-27 19:42

writing byte-compilation script '/tmp/'
/usr/bin/python -O /tmp/
removing /tmp/
running install_egg_info
Writing /tmp/yaourt-tmp-edward/aur-python-pyqtgraph/pkg/python-pyqtgraph/usr/lib/python3.4/site-packages/pyqtgraph-0.9.10-py3.4.egg-info
running install_scripts
running build_scripts
error: cannot copy tree 'build/scripts-3.4': not a directory
==> ERROR: A failure occurred in package().
==> ERROR: Makepkg was unable to build python-pyqtgraph.

windel commented on 2015-01-02 10:54

The new version dropped its scipy dependency!

windel commented on 2014-10-03 07:28

Indeed this would be good, is there such a package for qt bindings? Also I am wondering why pyside is not yet in official repositories.

rpodgorny commented on 2014-08-04 10:06

just a side note: it would be nice if this would not depend on python-pyqt4 but on some virtual(?) package so it would be happy with python-pyside as well. ...or maybe add both to optdepends.

windel commented on 2013-12-04 21:17


python -m pyqtgraph.examples

To see some demos. Now also works better with python 3!