Package Details: python-qiskit-sdk-git 0.7.0.r2162.2fa71f56-6

Git Clone URL: https://aur.archlinux.org/python-qiskit-sdk-git.git (read-only)
Package Base: python-qiskit-sdk-git
Description: Python software development kit for writing quantum computing experiments, programs, and applications.
Upstream URL: http://www.qiskit.org
Keywords: experience ibm quantum
Licenses: Apache-2.0
Groups: QISKit
Conflicts: python-qiskit-sdk
Provides: python-qiskit-sdk
Submitter: DanMan
Maintainer: None
Last Packager: DanMan
Votes: 0
Popularity: 0.000000
First Submitted: 2017-12-11 06:15
Last Updated: 2018-12-21 17:05

Latest Comments

doublesack commented on 2019-07-10 10:45

And these: 'python-pylint' 'python-pycodestyle' 'python-sphinx' 'python-sphinxcontrib-fulltoc' 'python-coverage' 'python-better-apidoc' are not actually makedepends anymore. At least, I can build the package without them.

doublesack commented on 2019-07-10 09:14

Currently, I can only install this if I also install marshmallow_polyfield. Python-pip is also a dependency, as qiskit checks its version through pip. I will upload my marshmallow_polyfield PKGBUILD to the AUR shortly. Furthermore, cmake is not used to package 0.8.2. If I remove the line from the PKGBUILD I can build the package.

Or am I doing something wrong?

DanMan commented on 2018-09-14 15:30

Woops, silly mistake on my part. Should've actually tested the package before pushing the changes. Also, apparently python-jsonschema is an actual dependency not just a make dependency so I fixed that as well.

ixil commented on 2018-09-12 14:29

Thanks, another minor edit that's is barely worth fixing is the license file name should is LICENSE.txt on the repo and the package fails due to the name mismatch

DanMan commented on 2018-09-04 16:53

Pretty sure I'm not suppose to change the name of the package. To do that I would just release it under the new name. I don't see the point in changing the package name because the python module is still just called qiskit. I have updated the repo information in the PKGBUILD so it should at least work... until they change the name again of course.

ixil commented on 2018-08-30 18:12

Could this be renamed to python-qiskit-terra-git? since the repo changed names Cheers