Package Details: python-quantlib 1.11-1

Git Clone URL: https://aur.archlinux.org/python-quantlib.git (read-only)
Package Base: python-quantlib
Description: A Python binding for QuantLib.
Upstream URL: http://quantlib.org
Licenses: BSD
Submitter: qft
Maintainer: qft
Last Packager: qft
Votes: 3
Popularity: 0.001100
First Submitted: 2016-05-27 14:15
Last Updated: 2017-12-12 17:23

Latest Comments

jrvarma commented on 2018-07-05 16:00

I made the following changes to install version 1.13 pkgver=1.13 depends=("quantlib>=1.13" "python") source=("$_pkgname-$pkgver.tar.gz::https://bintray.com/quantlib/releases/download_file?file_path=$_pkgname-$pkgver.tar.gz") sha256sums=('0ab99d6a43b2a204d6366fb600aa3cd049ee29e1d0406fefaedcc0f4fd9c65c2')

qft commented on 2016-09-24 01:44

Please note there is no 1.8.1 version for this package. According to the official website, "The SWIG interfaces for QuantLib 1.8 work with QuantLib 1.8.1 as well".

JohnRobson commented on 2016-06-04 04:22

Thank you very much qft, I fixed the problem. I forgot an old version (1.6) inside the "/usr/local/include" folder, maybe an old manual installation.

BTW, this package ask for a LOT of memory to compile and install.

qft commented on 2016-06-04 03:23

HI JohnRobson,

If you read the source of quantlib_wrap.cpp, the relevant part is this:
#if QL_HEX_VERSION < 0x010800f0
#error using an old version of QuantLib, please update
#endif

You will only see this error if your quantlib verions is less than 1.8. Can you check the file /usr/include/ql/version.hpp to see what's the value of QL_HEX_VERSION?

JohnRobson commented on 2016-06-04 03:06

cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
QuantLib/quantlib_wrap.cpp:3986:6: error: #error using an old version of QuantLib, please update
#error using an old version of QuantLib, please update

I'm using QuantLib 1.8.1 (https://aur.archlinux.org/packages/quantlib/)