Package Details: python-requests-cache 1.2.0-1

Git Clone URL: https://aur.archlinux.org/python-requests-cache.git (read-only, click to copy)
Package Base: python-requests-cache
Description: A persistent cache for python requests
Upstream URL: https://github.com/requests-cache/requests-cache
Keywords: cache dynamodb http mongodb performance redis requests sqlite web webscraping
Licenses: custom:BSD-2-clause
Submitter: Shibumi
Maintainer: carlosal1015 (JWCook, flying-sheep, AutoUpdateBot)
Last Packager: AutoUpdateBot
Votes: 30
Popularity: 0.016407
First Submitted: 2015-09-21 13:55 (UTC)
Last Updated: 2024-02-18 07:57 (UTC)

Dependencies (24)

Sources (1)

Latest Comments

1 2 3 4 5 6 .. 9 Next › Last »

carlosal1015 commented on 2024-01-19 16:41 (UTC)

Hi @hearth, please try again.

hearth commented on 2024-01-19 11:20 (UTC)

Incorrect checksum today:

==> Validating source files with sha512sums...
    requests-cache-1.1.1.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!

carlosal1015 commented on 2023-05-21 00:00 (UTC)

Hi @hexadecagram, could you uninstall all the dependencies and reinstall requests-cache.

hexadecagram commented on 2023-05-20 23:56 (UTC)

python-url-normalize, which this package also depends upon, is still installing into /usr/lib/python3.10/. Below is the log that python-requests-cache produces. I have reported this to the python-url-normalize package maintaners.

==> Starting check()...
ImportError while loading conftest '/home/_/.cache/yay/python-requests-cache/src/requests-cache-1.0.1/tests/conftest.py'.
tests/conftest.py:31: in <module>
    from requests_cache import ALL_METHODS, CachedSession, install_cache, uninstall_cache
requests_cache/__init__.py:7: in <module>
    from .backends import *
requests_cache/backends/__init__.py:7: in <module>
    from .base import BaseCache, BaseStorage, DictStorage
requests_cache/backends/base.py:19: in <module>
    from ..cache_keys import create_key, redact_response
requests_cache/cache_keys.py:28: in <module>
    from url_normalize import url_normalize
E   ModuleNotFoundError: No module named 'url_normalize'
==> ERROR: A failure occurred in check().
    Aborting...
 -> error making: python-requests-cache-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
python-requests-cache - exit status 4

carlosal1015 commented on 2023-05-06 13:38 (UTC)

Hi @hamelg, the reason is that all python-packages must be rebuilt by users when python reach a major version.

See https://aur.archlinux.org/packages/python-requests-cache#comment-842175 and https://www.reddit.com/r/archlinux/comments/136uxj8/python_311_is_in_the_repos_now_o/

Solution: Rebuild python-timeout-decorator, if all is ok you will find the module over /usr/lib/python3.11/ when check with pacman -Ql python-timeout-decorator.

hamelg commented on 2023-05-06 13:02 (UTC) (edited on 2023-05-06 13:08 (UTC) by hamelg)

Here is, the build fails with this error :

ImportError while loading conftest '/home/xxxxxxx/.cache/yay/python-requests-cache/src/requests-cache-1.0.1/tests/conftest.py'.
tests/conftest.py:29: in <module>
    from timeout_decorator import timeout
E   ModuleNotFoundError: No module named 'timeout_decorator'

EDIT: With python 3.11, the package python-timeout-decorator must be rebuild.

carlosal1015 commented on 2023-05-05 17:23 (UTC)

Hi @solsticedhiver, according to pyproject.toml, python-bson is an optional dependency. Could you please share the log (hint: upload to https://pastebin.com).

solsticedhiver commented on 2023-05-04 12:10 (UTC)

this package shouldn't depend on python-bson?; Does not build right now

carlosal1015 commented on 2023-03-02 14:19 (UTC)

Thanks @Vitrum-cnkj34kr8. Enjoy the new version!

Vitrum-cnkj34kr8 commented on 2023-03-02 05:52 (UTC) (edited on 2023-03-02 05:53 (UTC) by Vitrum-cnkj34kr8)

Incorrect checksum:

==> Validating source files with sha512sums...
    requests-cache-1.0.0.tar.gz ... FAILED