Package Details: python-scapy-git 2.5.0.dev5-1

Git Clone URL: (read-only, click to copy)
Package Base: scapy-git
Description: Powerful interactive packet manipulation program written in Python (library)
Upstream URL:
Licenses: GPL2
Conflicts: python-scapy
Provides: python-scapy
Submitter: anthraxx
Maintainer: plt
Last Packager: plt
Votes: 3
Popularity: 0.000000
First Submitted: 2016-01-18 01:33 (UTC)
Last Updated: 2023-01-16 21:22 (UTC)

Dependencies (15)

Required by (13)

Sources (1)

Latest Comments

1 2 Next › Last »

MarsSeed commented on 2022-07-01 23:33 (UTC)

Thank you for the prompt response and for being so helpful. :)

plt commented on 2022-07-01 19:00 (UTC)

Should be alright now, thanks @MarsSeed!

MarsSeed commented on 2022-07-01 18:41 (UTC)

Though this still supports Python 2, the package cannot be built because of missing Python 2 dependencies.

So the python2- subpackage needs to be dropped for this to be possible to build and package.

PedroHLC commented on 2020-01-07 21:51 (UTC)

Should this package move away from python2 now that it's EOLd?

Cyber_STX commented on 2019-04-26 05:34 (UTC)

Hi. I now have an error when trying to run scapy from the cli or when doing a "from scapy.all import *"

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 583, in _build_master
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 791, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.VersionConflict: (scapy git-archive.devbad14cb1a (/usr/lib/python3.7/site-packages), Requirement.parse('scapy==2.4.3rc1.dev105'))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/scapy", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3241, in <module>
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3225, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3254, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 585, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 598, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'scapy==2.4.3rc1.dev105' distribution was not found and is required by the application


plt commented on 2019-03-03 11:33 (UTC)

Totally @Cyber_STX. You need to apply the following patch to PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index df64e6e..80616e7 100644
@@ -27,7 +27,7 @@ prepare() {
   cp -a ${pkgbase}{,-py2}
   cd ${pkgbase}-py2
   sed -e 's|env python|env python2|g' -i doc/scapy/*.rst scapy/contrib/*.py \
-    run_scapy scapy/ scapy/tools/ scapy/layers/*.py bin/*
+    run_scapy scapy/ scapy/tools/ scapy/layers/*.py

 build() {

Cyber_STX commented on 2019-03-01 17:42 (UTC)

Hi there,

There is an error when trying to install this package:

==> Starting prepare()...
sed: can't read bin/*: No such file or directory
==> ERROR: A failure occurred in prepare().
Error making: scapy-git


anthraxx commented on 2018-03-07 18:13 (UTC)

gonna try it a bit and create a split package out of it so the libs support both. will take a bit of rewrite and testing but it will happen.

Cyber_STX commented on 2018-03-07 17:51 (UTC)

Hi @plt

Sure, I think it would be a good idea to switch to python 3, I spoke with one of the dev and the port is going well. Reported a bug and it was fixed in 2 hours. I'm using a custom script right now to update it from the git but clearly would prefer if this package was made to be compatible with both.

plt commented on 2018-01-10 16:25 (UTC)


@Cyber_STX that should be fixed now.

We should probably switch to Python 3 BTW, since 2.4 (including RC) are compatible with both versions, and have a python2-scapy including only the Python library. What do you think?