Package Details: python-scipy-mkl 1.3.1-1

Git Clone URL: https://aur.archlinux.org/python-scipy-mkl.git (read-only)
Package Base: python-scipy-mkl
Description: SciPy is open-source software for mathematics, science, and engineering.
Upstream URL: http://www.scipy.org/
Licenses: BSD
Conflicts: python-scipy
Provides: python-scipy=1.3.1
Submitter: bred
Maintainer: petronny
Last Packager: petronny
Votes: 27
Popularity: 0.054697
First Submitted: 2012-09-06 19:34
Last Updated: 2019-08-15 13:08

Required by (304)

Sources (2)

Pinned Comments

petronny commented on 2019-06-26 08:47

Prebuilt binaries of this package can be found in arch4edu.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

RunAndTumble commented on 2019-01-22 21:36

@petronny thanks for the SHA fix. However, I still have that issue with the compiler. I tried to build it locally & install directly but no result so far. Any ideas?

RunAndTumble commented on 2019-01-18 15:25

@petronny SHA sums check fails

P.S. since we do not use gcc, it's probably good to remove it from the dependency list. P.P.S. "CompilerNotFound()" again

RunAndTumble commented on 2019-01-16 21:28

Well, this is awkward: I started getting "CompilerNotFound()" as well. I'm pretty sure that I didn't change anything and I had it installed (had to remove to reinstall numpy)

UPD. I feel that this is related to icc somehow, since it's been updated recently. However, I do not see how this might change the outcome.

petronny commented on 2018-12-14 11:43

@Maverick You need to install the license for intel's compilers.

Maverick commented on 2018-12-14 02:21

Still getting the "CompilerNotFound()" message despite installed mkl, as alleut has described. What should I do?

petronny commented on 2018-11-22 04:49

Long time passed, and I still don't find a way to fix the python2 version. Can we deprecate it?

aoowweenn commented on 2018-09-07 17:57

Since setuptools changed a lot, please update the gcc part:

line 63, python3 setup.py build --fcompiler=gnu95 --compiler=unix

line 80, python2 setup.py build --fcompiler=gnu95 --compiler=unix

line 122, python3 setup.py config --compiler=unix config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}/" --optimize=1

line 145, python2 setup.py config --compiler=unix config_fc --fcompiler=gnu95 install --prefix=/usr --root="${pkgdir}/" --optimize=1

petronny commented on 2018-08-20 05:25

AFAIK, Python 3.7 works fine. The problem is the new version of numpy is not compatible with scipy when using python 2.7. I'm trying to solve this.

bred commented on 2018-08-16 18:41

Somebody has figure out how to compile scipy-mkl with python 3.7 ????

petronny commented on 2018-07-19 04:15

python-scipy-mkl has a literal $pkgver in its provides. This happens because you have enclosed these variables in strong quotes.

Forwarded from https://github.com/arch4edu/arch4edu/issues/17