Package Details: python-shreddit-git r377.b0c9ea2-1

Git Clone URL: https://aur.archlinux.org/python-shreddit-git.git (read-only, click to copy)
Package Base: python-shreddit-git
Description: Remove your comment history on Reddit as deleting an account does not do so.
Upstream URL: https://github.com/jdbassa/Shreddit
Licenses: BSD
Conflicts: python-shreddit
Provides: python-shreddit
Submitter: ardeaf
Maintainer: ardeaf
Last Packager: ardeaf
Votes: 6
Popularity: 0.014525
First Submitted: 2017-06-09 01:19
Last Updated: 2019-10-31 21:26

Latest Comments

10479 commented on 2019-11-21 21:29

Is anyone here having an issue since upgrading to Python 3.8?

edit - remove package and do a clean build and it will properly install in 'python3.8 and function again

ardeaf commented on 2019-11-18 11:05

Package updated, all the errors below should be fixed.

aNewDay commented on 2019-08-16 13:45

When building: error: invalid command 'bdist_wheel' error Failed building wheel for shreddit

-

ERROR: Failed to build one or more wheels Exception information: Traceback (most recent call last): File "/usr/lib/python3.7/site-packages/pip/_internal/cli/base_command.py", line 179, in main status = self.run(options, args) File "/usr/lib/python3.7/site-packages/pip/_internal/commands/wheel.py", line 178, in run "Failed to build one or more wheels" pip._internal.exceptions.CommandError: Failed to build one or more wheels

When executing:

File "/usr/bin/shreddit", line 11, in <module> load_entry_point('shreddit==6.0.7', 'console_scripts', 'shreddit')() File "/usr/lib/python3.7/site-packages/shreddit/app.py", line 53, in main shredder = Shredder(default_config, args.user) File "/usr/lib/python3.7/site-packages/shreddit/shredder.py", line 33, in init self._recent_cutoff = arrow.now().replace(hours=-self._hours) File "/usr/lib/python3.7/site-packages/arrow/arrow.py", line 590, in replace raise AttributeError('unknown attribute: "{}"'.format(key)) AttributeError: unknown attribute: "hours"

KopfKrieg commented on 2019-08-03 21:57

Please add python-dateutil as required dependency, I had to manually install it.

aNewDay commented on 2019-06-29 20:18

Works great. Thank you! Follow the directions here to set it up after installation: https://github.com/x89/Shreddit