Package Details: python-social-auth-core 4.3.0-1

Git Clone URL: https://aur.archlinux.org/python-social-auth-core.git (read-only, click to copy)
Package Base: python-social-auth-core
Description: Python Social Auth core component
Upstream URL: https://github.com/python-social-auth/social-core
Licenses: BSD
Submitter: pmattern
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 1
Popularity: 0.000000
First Submitted: 2017-01-30 22:47 (UTC)
Last Updated: 2022-06-17 00:05 (UTC)

Latest Comments

Voklen commented on 2021-09-01 06:31 (UTC)

@BubuIIC If they don't reply within another day or two maybe split this package up into python-social-auth-core-3 and then update python-social-auth-core

BubuIIC commented on 2021-08-31 16:37 (UTC)

@Voklen: I did so 8 days ago and didn't receive a reply yet.

Voklen commented on 2021-08-31 16:09 (UTC)

@BubuIIC I would agree with Vasi, try contacting the PyJWT arch maintainer https://archlinux.org/packages/community/any/python-pyjwt/ and asking them why its still on 1.7.1

BubuIIC commented on 2021-08-21 12:05 (UTC) (edited on 2021-08-21 12:29 (UTC) by BubuIIC)

@Voklen, I've adopted the package, I was previously hesitant to do so because upstream says it depends on PyJWT >= 2.0 which arch still isn't packaging.

I'm unsure if I should update this reagrdless, ignoring the version dependency or if i should make the package require PyJWT 2.0, which people then would need to manually upgrade to until arch ships it.

Edit: Asked on arch-general about updating pyjwt.

Voklen commented on 2021-08-14 12:20 (UTC)

Hi, could you update the pkgver to be 4.1.0 (and of course change the sha256sums as well). I've tried it and it works fine for me.

L0ric0 commented on 2019-12-01 17:52 (UTC)

as the posibility of building just a part of the packages in a split package has been removed from makepkg and python2 is not needed for a archlinux install it would be nice to split this package into python2 and 3 so that one does not have to install python2