Package Details: python-socks 1.6.8-1

Git Clone URL: https://aur.archlinux.org/python-socks.git (read-only)
Package Base: python-socks
Description: SOCKS4, SOCKS5 or HTTP proxy (Anorov fork PySocks replaces socksipy)
Upstream URL: https://github.com/Anorov/PySocks
Licenses: BSD
Conflicts: python-socksipy-branch
Provides: python-socksipy-branch
Replaces: python-socksipy-branch
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 76
Popularity: 0.000027
First Submitted: 2014-02-01 23:25
Last Updated: 2019-01-10 08:19

Required by (2)

Sources (1)

Latest Comments

sl1pkn07 commented on 2019-02-11 15:32

python-socks and python2-socks in [Comunnity] as python-pysocks and python2-pysocks

mschu commented on 2014-09-26 08:46

I missed the previous comment, my mistake.
Now correctly depends on python instead of python2.

For naming, the package follows the https://wiki.archlinux.org/index.php/Python_Package_Guidelines, see "Package naming"

vadmium commented on 2014-09-26 02:03

At the moment this looks like a Python 2 package, unless you study the package() function. Fixing the dependency is definitely needed; it wouldn’t hurt to mention Python 3 in the package name or description either.

vadmium commented on 2014-09-26 01:41

I suggest you mention “Python” in the package name or description

qmega commented on 2014-06-12 05:10

Should depend on python, not python2.

mutantmonkey commented on 2014-02-02 01:41

This package is deprecated. Please use python-socks instead. Disowning.

mschu commented on 2012-06-11 08:53

Created a separate package at https://aur.archlinux.org/packages.php?ID=59942. Feel free to merge if you deem it appropriate.

mschu commented on 2012-06-10 15:14

Please consider switching the sources to an improved branch on google code: http://code.google.com/p/socksipy-branch/ (source updated 2010 compared to 2006 with the bugs from SF.net fixed).

doorknob60 commented on 2010-10-10 22:55

Here's a new PKGBUILD, it uses a little sed magic to determine your python version, but it seems to work well :)

http://aur.pastebin.com/jMjxSsDX

doorknob60 commented on 2010-10-08 06:01

Flagged out of date because it does not work with the python updates in [testing]. While not everyone uses testing, making it compatible with [testing] will not break compatibility for people that don't use it (the python package in [extra] provides python2, and python2 is symlinked to the correct executable).