Package Details: python-spotify-ripper-git r451.d046419-1

Git Clone URL: https://aur.archlinux.org/python-spotify-ripper-git.git (read-only)
Package Base: python-spotify-ripper-git
Description: Command-line ripper for Spotify (python3)
Upstream URL: https://github.com/hbashton/spotify-ripper
Licenses: MIT
Provides: python-spotify-ripper
Submitter: vsilv
Maintainer: vsilv
Last Packager: vsilv
Votes: 0
Popularity: 0.000000
First Submitted: 2017-10-28 13:15
Last Updated: 2017-10-28 13:15

Latest Comments

dreieck commented on 2018-02-13 17:02

Also, the package installs a file /usr/bin/main.py. I think a 'main.py' should not be under /usr/bin (but, if needed, e.g. unter some /usr/lib/spotify-ripper/[...] directory).

I haven't fixed it yet.

dreieck commented on 2018-02-13 16:57

Patch that allows for pyspotify, colorama and mutagen to be also higher version:

requirements.txt.patch::http://ix.io/GRE

Updated PKGBUILD:

PKGBUILD::http://ix.io/GRS

Patch between vsilv's PKGBUILD and my updated one:

python-spotify-ripper-git-PKGBUILD.patch::http://ix.io/GRU

dreieck commented on 2017-11-25 14:45

Dear maintainer,

can you package a patch that changes the "==" to ">=" in the requires.txt?

Thanks!

mezcal commented on 2017-11-06 21:12

Vsliv. Thank you. It is working for me too.

vsilv commented on 2017-11-05 14:49

Dear Mezcal,
I got the same error. My fast work-around is the following: The origin is a strangely-configured requires.txt, which you can find in python.../site-packages/spotify_ripper-2.9.1-...egg-info, you have to change the dependencies from the == sign to the >= sign:

pyspotify>=2.0.5
colorama>=0.3.3
mutagen>=1.30
requests>=2.3.0
schedule>=0.3.1

This worked for me.

mezcal commented on 2017-11-05 09:52

Hello,

I see this error:

pkg_resources.DistributionNotFound: The 'mutagen==1.30' distribution was not found and is required by spotify-ripper

Is it working for you?