Package Details: python-tablib 0.11.2-1

Git Clone URL: https://aur.archlinux.org/python-tablib.git (read-only)
Package Base: python-tablib
Description: Format-agnostic tabular data library (XLS, JSON, YAML, CSV)
Upstream URL: http://python-tablib.org
Licenses: MIT
Submitter: djscholl
Maintainer: djscholl
Last Packager: djscholl
Votes: 3
Popularity: 0.000000
First Submitted: 2010-12-25 20:39
Last Updated: 2016-03-02 13:03

Latest Comments

djscholl commented on 2015-04-03 17:37

Arch version bump for the change to a split package which builds for both Python 3 and 2. Thanks to Arch user carl.george for his guidance and draft PKGBUILD.

carlwgeorge commented on 2015-03-19 13:42

There isn't specific documentation for it, but there are bits and pieces scattered through the PKGBUILD documentation. Search for the word "split" in these links.

https://wiki.archlinux.org/index.php/PKGBUILD
https://www.archlinux.org/pacman/PKGBUILD.5.html

Here is are some examples of a split packages I maintain.

https://aur.archlinux.org/packages/py/python-click/PKGBUILD
https://aur.archlinux.org/packages/py/python-falcon/PKGBUILD

Here you go, I went ahead and wrote one for you.

http://pastebin.com/3hxvvNkH

Before you can upload a source package based on this, you have to click "File Request" and ask a TU to merge the two packages.

djscholl commented on 2015-03-18 23:42

@carl.george: I would consider making a split package, but I don't know how. I reviewed the Arch docs I knew about and searched the wiki and forum but didn't find anything. Do you have a URL for split Python packaging?

carlwgeorge commented on 2015-03-16 21:12

Please consider replacing this package and the python3 version with a split package that supports python 2 and 3.

carlwgeorge commented on 2015-03-16 21:12

Please consider replacing this package and the python2 version with a split package that supports python 2 and 3.

djscholl commented on 2014-05-04 03:38

This package as of pkgrel=2 is now intended to be Python 3, and python2-tablib has been forked as a separate AUR package. Unfortunately, this package does not work for me. I apologize for uploading a non-working PKGBUILD. I did this because I corrected and updated the PKGBUILD, and I wanted to make those improvements available, even though they are not enough to make it work. 0.9.11 is the last upstream release. The breakage I am seeing may have been fixed in recent commits on github, but I have to research this. If you know more about this than I do, please post your advice.

djscholl commented on 2014-05-04 03:16

New AUR package, forked from python-tablib for applications that are not ready to switch to Python 3. My plan is to convert python-tablib to a Python 3 package.

jleclanche commented on 2014-04-28 17:24

Please move to python2-tablib, this is the wrong name for it.

djscholl commented on 2012-04-17 21:01

Update for new upstream version, thanks to Arch user Mineo.