Package Details: python-telegram-bot 21.3-1

Git Clone URL: https://aur.archlinux.org/python-telegram-bot.git (read-only, click to copy)
Package Base: python-telegram-bot
Description: A library that provides a Python interface to the Telegram Bot API
Upstream URL: https://github.com/python-telegram-bot/python-telegram-bot
Keywords: telegram
Licenses: GPL-3.0-or-later, LGPL-3.0-or-later
Submitter: arojas
Maintainer: carlosal1015
Last Packager: carlosal1015
Votes: 2
Popularity: 0.000964
First Submitted: 2022-04-01 18:31 (UTC)
Last Updated: 2024-06-07 21:15 (UTC)

Pinned Comments

carlosal1015 commented on 2022-04-14 14:24 (UTC) (edited on 2023-01-01 17:19 (UTC) by carlosal1015)

Important note: Is recommended to read the documentation and receive the following key before to install:

$ curl -s https://raw.githubusercontent.com/python-telegram-bot/python-telegram-bot/v20.0/public_keys/v20.0-current.gpg | gpg --import

Also is possible skip the verification, adding the flag for (e.g makepkg, yay) --skippgpcheck, --nopgpfetch, respectively.

Latest Comments

1 2 Next › Last »

BoostCookie commented on 2024-05-04 22:30 (UTC)

I think you should set pkgrel=2 to trigger a new build for the new python version.

Henry-ZHR commented on 2023-05-08 02:56 (UTC)

SRCINFO missing some makedepends listed in PKGBUILD

Felixoid commented on 2023-01-09 20:01 (UTC)

It's fixed by adding the key to keyserver https://github.com/python-telegram-bot/python-telegram-bot/issues/3494#issuecomment-1376171688

Felixoid commented on 2023-01-08 22:06 (UTC)

Just asked the maintainers to publish the key to key-servers, so feel free to upvote

jussihi commented on 2022-12-09 11:24 (UTC) (edited on 2022-12-09 11:38 (UTC) by jussihi)

pkg_resources.DistributionNotFound: The 'tornado==6.1' distribution was not found and is required by python-telegram-bot

I guess the right version of tornado should be added as dependency

EDIT: ahh, it seems like Arch repo has too recent version of it (6.2 instead of 6.1)

Edit 2: Tornado seems to be pinned to 6.1 in latest telegram-bot update (https://github.com/python-telegram-bot/python-telegram-bot/pull/3145). Should this repo move to v20 releases of telegram-bot? Those versions (v20+) support Arch Linux's upstream packages (namely python-tornado v 6.2 and friends)

carlosal1015 commented on 2022-05-02 02:51 (UTC) (edited on 2022-05-02 02:54 (UTC) by carlosal1015)

Thanks for asking. Let me figure out what changed. 1, 2, 3.

vatai commented on 2022-05-02 02:14 (UTC)

Hi! Why do you have export PYTHONHASHSEED=0 in the PKGBUILD?

carlosal1015 commented on 2022-04-16 14:50 (UTC) (edited on 2022-04-16 14:59 (UTC) by carlosal1015)

Hi folks, last week I asked on telegram group about the warning.

This sed fix comes from the [community] repository, I have not used this package until it went into the AUR. If upstream said that it is ok, or have an example where the bot is working bad it is possible to change urllib3 to vendor one.

I will take a look this line if is commented according to python conventions.

carlosal1015 commented on 2022-04-14 14:24 (UTC) (edited on 2023-01-01 17:19 (UTC) by carlosal1015)

Important note: Is recommended to read the documentation and receive the following key before to install:

$ curl -s https://raw.githubusercontent.com/python-telegram-bot/python-telegram-bot/v20.0/public_keys/v20.0-current.gpg | gpg --import

Also is possible skip the verification, adding the flag for (e.g makepkg, yay) --skippgpcheck, --nopgpfetch, respectively.

post-factum commented on 2022-04-05 13:34 (UTC)

This:

sed -e '/telegram.utils.deprecate.TelegramDeprecationWarning/i \    ignore:python-telegram-bot is using upstream urllib3. This is allowed but not supported by python-telegram-bot maintainers.:UserWarning' \
    -i setup.cfg

doesn't seem to work.