Package Details: python-telegram-bot-git 1:20.0a0.r5.23ed0880-1

Git Clone URL: https://aur.archlinux.org/python-telegram-bot-git.git (read-only, click to copy)
Package Base: python-telegram-bot-git
Description: A Python wrapper around the Telegram Bot API
Upstream URL: https://github.com/python-telegram-bot/python-telegram-bot
Keywords: ptb telegram-bot
Licenses: LGPL3
Conflicts: python-telegram-bot
Provides: python-telegram-bot
Submitter: evgfilim1
Maintainer: evgfilim1 (specter119)
Last Packager: evgfilim1
Votes: 5
Popularity: 0.056039
First Submitted: 2017-05-14 15:47 (UTC)
Last Updated: 2022-05-11 13:59 (UTC)

Required by (8)

Sources (1)

Latest Comments

1 2 Next › Last »

Kewl commented on 2022-05-12 16:48 (UTC)

Anyone else getting ImportError: cannot import name 'Filters' from 'telegram.ext', any fix?

evgfilim1 commented on 2022-05-11 14:01 (UTC)

@Kewl Thanks for reporting, I've updated dependencies.

Kewl commented on 2022-05-09 07:58 (UTC)

The requirements have changed: httpx is required and certifi is no longer required.

specter119 commented on 2021-05-17 03:38 (UTC) (edited on 2021-05-17 03:46 (UTC) by specter119)

@Thempra Thanks for reporting. This AUR is the -git version, you can always get the latest version during (re-)building.

The -git AUR is maintained for its developer, their update is needed only when build processing changes, e.g. dependencies updated. However, daily users can also keep the -git AUR updated (in some degrees) with the help of the AUR helper.

FYI: https://wiki.archlinux.org/title/Arch_User_Repository#What_is_the_difference_between_foo_and_foo-git_packages?

Then, would you please remove the outdated tag?

Thempra commented on 2021-05-16 16:03 (UTC) (edited on 2021-05-16 16:05 (UTC) by Thempra)

Please, can you update to version 13.5? Thx !!


---
 PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD
index 6daf105..7eed2bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@

 pkgname=('python-telegram-bot-git')
 epoch=1
-pkgver=13.3.r0.e9c01c77
+pkgver=13.5
 pkgrel=1
 pkgdesc="A Python wrapper around the Telegram Bot API"
 arch=('any')
-- 

evgfilim1 commented on 2021-02-11 07:16 (UTC)

Looks like python-apscheduler 2.7.0 is backwards compatible with 2.6.3 despite being locked in upstream's requirements.txt.

@Eothred thanks for reporting, package updated.

Eothred commented on 2021-02-10 07:40 (UTC)

This package blocks upgrade of python-apscheduler

evgfilim1 commented on 2020-11-18 15:29 (UTC)

@specter119 thanks, package updated

specter119 commented on 2020-11-08 16:31 (UTC)

need new deps: python-apscheduler and python-pytz