Package Details: python-tiktoken-git 0.5.1.r0.g39f29ce-1

Git Clone URL: https://aur.archlinux.org/python-tiktoken-git.git (read-only, click to copy)
Package Base: python-tiktoken-git
Description: A fast BPE tokeniser for use with OpenAI's models
Upstream URL: https://github.com/openai/tiktoken
Licenses: MIT
Conflicts: python-tiktoken
Provides: python-tiktoken
Submitter: dreieck
Maintainer: xiota
Last Packager: xiota
Votes: 0
Popularity: 0.000000
First Submitted: 2023-02-14 21:10 (UTC)
Last Updated: 2023-11-14 23:27 (UTC)

Required by (9)

Sources (1)

Latest Comments

xiota commented on 2023-11-24 12:32 (UTC)

@xeruf Try building in clean chroot. whisper-git doesn't require this (works with extra/python-tiktoken).

xeruf commented on 2023-11-24 12:07 (UTC) (edited on 2023-11-24 12:08 (UTC) by xeruf)

unable to build right now, need it for whisper

Cloning into 'python-tiktoken'...
done.
==> Starting prepare()...
    Updating crates.io index
error: failed to select a version for the requirement `bstr = "^1.5.0"`
candidate versions found which didn't match: 0.2.17, 0.2.16, 0.2.15, ...
location searched: crates.io index
required by package `tiktoken v0.5.1 (/home/janek/.local/cache/yay/python-tiktoken-git/src/python-tiktoken)`
==> ERROR: A failure occurred in prepare().
    Aborting...
 -> error making: python-tiktoken-git-exit status 4

dreieck commented on 2023-04-25 11:27 (UTC)

I am disowning because the project that (initially?) need(ed?) it changes too quickly, see this comment for revchatgpt-git.