Package Details: python-torchmetrics 1.3.2-1

Git Clone URL: https://aur.archlinux.org/python-torchmetrics.git (read-only, click to copy)
Package Base: python-torchmetrics
Description: Machine learning metrics for distributed, scalable PyTorch applications
Upstream URL: https://github.com/PyTorchLightning/metrics
Licenses: Apache-2.0
Submitter: hottea
Maintainer: alhirzel
Last Packager: alhirzel
Votes: 2
Popularity: 0.194771
First Submitted: 2021-04-01 09:02 (UTC)
Last Updated: 2024-03-31 02:56 (UTC)

Latest Comments

Romanovzky commented on 2024-04-20 15:45 (UTC)

Why does this depend on python-transformers? It ends up installing a lot of things that are completely unnecessary for PyTorch lightning as this is set as dependency of python-pytorch-lightning. See here for strict dependencies: https://github.com/Lightning-AI/torchmetrics/blob/master/requirements/base.txt

Freed commented on 2023-03-11 03:40 (UTC) (edited on 2023-03-11 03:43 (UTC) by Freed)

@alhirzel I have invited you in python-torch-fidelity and python-lpips. In /usr/lib/python3.10/site-packages/torchmetrics-0.11.1-py3.10.egg-info/requires.txt I found more packages scipy, ... it looks like some of them are optdepends, too. (scipy is the optdepend for FID)

alhirzel commented on 2023-03-10 17:41 (UTC) (edited on 2023-03-10 17:43 (UTC) by alhirzel)

@Freed I bumped this package, thanks for your note. Do you want me to package FID on the AUR?

Freed commented on 2023-03-10 17:14 (UTC)

Miss optdepends: python-lpips for LPIPS and python-fidelity for FID.