Package Details: python-ufoprocessor 1.7-1

Git Clone URL: https://aur.archlinux.org/python-ufoprocessor.git (read-only)
Package Base: python-ufoprocessor
Description: Python package based on fontTools.designSpaceLib for processing and generating UFO files.
Upstream URL: https://pypi.org/project/ufoProcessor
Licenses: MIT
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 0
Popularity: 0.000000
First Submitted: 2019-11-12 18:00
Last Updated: 2019-11-12 18:00

Latest Comments

yochananmarqos commented on 2019-11-15 15:34

@caleb: See the setup.py:

setup_requires=wheel + ["setuptools_scm"],

It uses it for package versioning:

use_scm_version={"write_to": "Lib/ufoProcessor/_version.py"},

caleb commented on 2019-11-15 10:03

Why does this depend on python-setuptools-scm? What is wrong with python-setuptools?

Edit: I've confirmed this works fine without -scm.