Package Details: python-validators 0.12.0-1

Git Clone URL: https://aur.archlinux.org/python-validators.git (read-only)
Package Base: python-validators
Description: Python data validation for humans
Upstream URL: https://pypi.python.org/pypi/validators
Licenses: custom
Submitter: sanerb
Maintainer: sanerb
Last Packager: sanerb
Votes: 2
Popularity: 0.890952
First Submitted: 2016-11-20 22:07
Last Updated: 2017-07-17 08:27

Pinned Comments

sanerb commented on 2016-11-21 05:24

# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net

(If you want an RSS-feed only pertaining to my AUR packages, you can subscribe to https://devblog.square-r00t.net/rss/?category=aur in your favourite RSS reader.)

Note that you should still use the AUR web interface for flagging packages as out-of-date if a new version is released; the aforementioned bug tracker is to aid in issues with building/packaging/the PKGBUILD formats/etc. specifically.

GPG signature "errors" are explained here:
https://devblog.square-r00t.net/articles/a-note-on-using-gpg-signatures-in-pkgbuilds

Please read; it's not a bug.


Thanks!

Latest Comments

sanerb commented on 2017-11-07 07:31

a hint, if you need it:

"==> Verifying source file signatures with gpg...
validators-0.12.0.tar.gz ... FAILED (unknown public key 8C004C2F93481F6B)
==> ERROR: One or more PGP signatures could not be verified!"

https://devblog.square-r00t.net/articles/a-note-on-using-gpg-signatures-in-pkgbuilds

note that this link is very clearly in the pinned comment:

"GPG signature "errors" are explained here:
https://devblog.square-r00t.net/articles/a-note-on-using-gpg-signatures-in-pkgbuilds"

sanerb commented on 2017-11-07 07:26

your AUR helper is broken.

==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issue...
==> Creating package "python-validators"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: python-validators 0.12.0-1 (Tue Nov 7 02:26:07 EST 2017)

timofonic commented on 2017-11-07 07:24

! $  /h/timofonic  sudo --user=timofonic pacaur -S python-validators
:: Package python-validators not found in repositories, trying AUR...
:: resolving dependencies...
:: looking for inter-conflicts...

AUR Packages (1) python-validators-0.12.0-1

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
:: python-validators build files are up-to-date -- skipping
:: Checking python-validators integrity...
==> Making package: python-validators 0.12.0-1 (Tue Nov 7 08:19:09 CET 2017)
==> Retrieving sources...
-> Found validators-0.12.0.tar.gz
-> Found validators-0.12.0.tar.gz.sig
==> Validating source files with sha512sums...
validators-0.12.0.tar.gz ... Passed
validators-0.12.0.tar.gz.sig ... Skipped
==> Verifying source file signatures with gpg...
validators-0.12.0.tar.gz ... FAILED (unknown public key 8C004C2F93481F6B)
==> ERROR: One or more PGP signatures could not be verified!
:: Preparing python-validators...
==> Making package: python-validators 0.12.0-1 (Tue Nov 7 08:19:10 CET 2017)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
-> Found validators-0.12.0.tar.gz
-> Found validators-0.12.0.tar.gz.sig
==> WARNING: Skipping all source file integrity checks.
==> Extracting sources...
-> Extracting validators-0.12.0.tar.gz with bsdtar
==> Sources are ready.
:: failed to verify integrity or prepare python-validators package

sanerb commented on 2017-07-17 08:27

ozwigh- sorry for the delay! thanks for the ping- updated to 0.12.0!

sanerb commented on 2016-11-21 05:24

# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net

(If you want an RSS-feed only pertaining to my AUR packages, you can subscribe to https://devblog.square-r00t.net/rss/?category=aur in your favourite RSS reader.)

Note that you should still use the AUR web interface for flagging packages as out-of-date if a new version is released; the aforementioned bug tracker is to aid in issues with building/packaging/the PKGBUILD formats/etc. specifically.

GPG signature "errors" are explained here:
https://devblog.square-r00t.net/articles/a-note-on-using-gpg-signatures-in-pkgbuilds

Please read; it's not a bug.


Thanks!