Package Details: python-waitress 0.8.9-1

Git Clone URL: https://aur.archlinux.org/python-waitress.git (read-only)
Package Base: python-waitress
Description: Waitress WSGI server
Upstream URL: https://github.com/Pylons/waitress
Licenses: ZPL
Submitter: fab31
Maintainer: None
Last Packager: fab31
Votes: 1
Popularity: 0.000000
First Submitted: 2012-01-03 19:08
Last Updated: 2015-07-15 08:13

Dependencies (1)

Required by (2)

Sources (1)

Latest Comments

pheerai commented on 2015-08-27 14:23

Doesn't build:

==> Building and installing package
==> ERROR: Missing package() function in /tmp/yaourt-tmp-pheerai/aur-python-waitress/./PKGBUILD
==> ERROR: Makepkg was unable to build python-waitress.
==> Restart building python-waitress ? [y/N]

When adding a simple package()-Function that does nothing but a simple echo, I get:

running install_lib
creating /tmp/yaourt-tmp-pheerai/aur-python-waitress/pkg/python-waitress
error: could not create '/tmp/yaourt-tmp-pheerai/aur-python-waitress/pkg/python-waitress': Permission denied
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build python-waitress.
==> Restart building python-waitress ? [y/N]
==> ----------------------------------------
==>

ModYokosuka commented on 2015-04-06 17:33

// Corrected PKGBUILD

# Contributor: Zope Foundation and Contributors
# Maintainer: Fabien Devaux <fdev 31 at gmail dot com>

pkgname=python-waitress
_pkgname=waitress
pkgver=0.8.9
pkgrel=1
pkgdesc="Waitress WSGI server"
arch=(any)
url="https://github.com/Pylons/waitress"
license=('ZPL')
depends=('python')

source=(http://pypi.python.org/packages/source/w/waitress/waitress-${pkgver}.tar.gz)
md5sums=('da3f2e62b3676be5dd630703a68e2a04')

build(){
cd ${srcdir}/${_pkgname}-${pkgver}
python2 setup.py build
}

package() {
cd ${srcdir}/${_pkgname}-${pkgver}
python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
}

garyvdm commented on 2014-03-27 18:52

Please bumb pkgrel for python 3.4.