Package Details: python-weasyprint 53.0-2

Git Clone URL: https://aur.archlinux.org/python-weasyprint.git (read-only, click to copy)
Package Base: python-weasyprint
Description: Convert web documents (HTML, CSS, SVG, ...) to PDF
Upstream URL: https://weasyprint.org
Licenses: BSD
Provides: weasyprint=53.0
Submitter: SimonSapin
Maintainer: alerque
Last Packager: alerque
Votes: 14
Popularity: 0.20
First Submitted: 2012-03-01 16:12
Last Updated: 2021-08-07 20:50

Dependencies (20)

Required by (11)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3

cinatic commented on 2017-12-14 13:36

bumped to new version, i did not found pdfrw in aur

xanc commented on 2017-12-14 13:25

It depends to pdfrw?

xanc commented on 2017-12-14 13:22

Latest version is 0.41. Can you upgrade the package? Thx

cinatic commented on 2017-03-10 10:47

thanks updated the package

sergiodlc commented on 2017-03-07 04:53

There's a missing dependency (python-xcffib). Can you add it? See traceback below:

import weasyprint
File "/usr/lib/python3.6/site-packages/weasyprint/__init__.py", line 361, in <module>
from .css import PARSER, preprocess_stylesheet # noqa
File "/usr/lib/python3.6/site-packages/weasyprint/css/__init__.py", line 30, in <module>
from . import computed_values
File "/usr/lib/python3.6/site-packages/weasyprint/css/computed_values.py", line 18, in <module>
from .. import text
File "/usr/lib/python3.6/site-packages/weasyprint/text.py", line 20, in <module>
import cairocffi as cairo
File "/usr/lib/python3.6/site-packages/cairocffi/__init__.py", line 18, in <module>
from ._ffi import ffi
File "/usr/lib/python3.6/site-packages/cairocffi/_ffi.py", line 3, in <module>
from xcffib._ffi import ffi as _ffi0
ModuleNotFoundError: No module named 'xcffib'

Franckinux commented on 2017-01-27 14:26

Lastest version is 0.34. Can you update the package ? Thanks.

cinatic commented on 2014-08-23 08:07

added additional dependencies and testing, works much better now (external links for images supported and such things)

SimonSapin commented on 2013-11-07 12:10

I’m not using this package anymore. I just "disowned" it, feel free to adopt and update it.

g1smo commented on 2013-11-07 10:53

Could you update this package?
You can add pip and other things as dependencies, then modify the install script so that pip installs/updates it.

SimonSapin commented on 2013-02-25 17:12

This package is not updated anymore. See http://weasyprint.org/install/