Package Details: python-wxpython-dev 4.2.1a1.dev5539+906adf71-1

Git Clone URL: https://aur.archlinux.org/python-wxpython-dev.git (read-only, click to copy)
Package Base: python-wxpython-dev
Description: Cross-platform GUI toolkit. Developer version
Upstream URL: https://www.wxpython.org
Licenses: custom:wxWindows
Conflicts: python-wxpython
Provides: python-wxpython
Submitter: dobedobedo
Maintainer: dobedobedo (kikislater)
Last Packager: dobedobedo
Votes: 1
Popularity: 0.000605
First Submitted: 2022-01-22 14:32 (UTC)
Last Updated: 2022-12-01 13:45 (UTC)

Required by (74)

Sources (1)

Latest Comments

1 2 3 Next › Last »

kikislater commented on 2022-08-01 10:21 (UTC) (edited on 2022-08-01 15:07 (UTC) by kikislater)

It's still needed for grass and ok for me regarding build

glenjo commented on 2022-07-24 19:08 (UTC)

Compiled clean for me. Thanks!

kikislater commented on 2022-07-24 11:45 (UTC)

I'll check by the end of the week ... I don't upgrade at this time as I have a work to be done ... But if community package is sufficient, I will not use this one anymore (needs to be tried) !

dobedobedo commented on 2022-07-24 07:33 (UTC)

I modified the PKGBUILD using the built-in WxWidgets files.
@kikislater, let me know if it has problems being compatible with grass.

glenjo commented on 2022-07-23 18:39 (UTC) (edited on 2022-07-23 19:03 (UTC) by glenjo)

I re-ran this and still have the failure. I am using the sip package. I also installed and tried with the sip4 package and got the same results, but let me try a bit more through testing and see what happens.

And the results. I modified the PKGBUILD so that the depends for sip was changed to sip4 and re-ran with the sip package removed and only the sip4 package installed - same results. So I see the build fail with both sip (version 6.6.2) or sip4 (version 4.19.25) installed.

dobedobedo commented on 2022-07-23 05:47 (UTC)

Hi, can you confirm if you use the sip package from the official repo? According to the error message, it seems that it's due to sip version incompatibility.
I tried to run makepkg for this PKGBUILD on a minimum Manjaro virtual machine, and couldn't reproduce this error. This PKGBUILD was modified from the PKGBUILD of the python-wxpython package from the repo, so it should theoretically work out-of-box.
@kikislater, could you please confirm if this package can be built on your side?

glenjo commented on 2022-07-22 16:13 (UTC) (edited on 2022-07-22 16:18 (UTC) by glenjo)

It's failing to compile for me too, here's the error-

sip-build --no-compile
Traceback (most recent call last):
  File "/usr/bin/sip-build", line 33, in <module>
    sys.exit(load_entry_point('sip==6.6.2', 'console_scripts', 'sip-build')())
  File "/usr/bin/sip-build", line 25, in importlib_load_entry_point
    return next(matches).load()
StopIteration
Command 'sip-build --no-compile' failed with exit code 1.
Finished command: sip (0.77s)
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: python-wxpython-dev

dobedobedo commented on 2022-07-20 08:24 (UTC)

I can't reproduce the error. Is the sip package from the extra repo? What is the full log?

UlvHare commented on 2022-07-20 07:57 (UTC) (edited on 2022-07-20 07:58 (UTC) by UlvHare)

4.2.0a1 cannot compile.

Running command: sip
sip-build --no-compile
Command 'sip-build --no-compile' failed with exit code 1.

dobedobedo commented on 2022-07-18 18:32 (UTC)

I made it to 4.2.0a1. Let me know if it works.