Package Details: python-yowsup 3.2.0-1

Git Clone URL: https://aur.archlinux.org/python-yowsup.git (read-only)
Package Base: python-yowsup
Description: The open source cross platform Whatsapp library powering Wazapp
Upstream URL: https://github.com/tgalal/yowsup
Licenses: GPL
Conflicts: python-yowsup-git, yowsup-client-git
Submitter: fanningert
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 2
Popularity: 0.036851
First Submitted: 2016-07-21 19:31
Last Updated: 2019-07-22 07:38

Latest Comments

1 2 Next › Last »

acmiudhg commented on 2019-05-10 15:44

Dependecy python-consonance is missing, here are the updated/new PKGBUILDs:

python2-yowsup does still not work, because python2-argparse is missing.

fordprefect commented on 2019-04-23 20:27

Update to 3.0.0. Only quick version bump, check() does not run through. If anyone has time to figure out whats rotten there (and how to fix it) please report!

slav commented on 2018-01-01 23:51

it is something wrong during build your package...

FAILED (errors=55) Test failed: <unittest.runner.texttestresult errors="55" failures="0" run="80"> error: Test failed: <unittest.runner.texttestresult errors="55" failures="0" run="80"> ==> ERROR: A failure occurred in check(). Aborting...</unittest.runner.texttestresult></unittest.runner.texttestresult>

fordprefect commented on 2017-10-24 06:32

@servimo: If there are any problems with your AUR wrapper, try with makepkg instead. It is the only supported tool. Also you consistently misspelled the package name with u instead of w, maybe thats part of your problem? I still can only guess what you do.

servimo commented on 2017-10-23 22:27

I already upgrade, but in Pamac appears two python-yousup:
python-yousup-2.5.0-4 and python2-yousup-2.5.2-1.
I removed python-yousup-2.5.0-4 amd everything is alright.
Could be something at my side. Thanks for your effort in understanding.

fordprefect commented on 2017-10-23 20:30

if you don't tell what you are doing, no one will ever find out what you are missing. You need to put in some effort if you want help.

fordprefect commented on 2017-10-23 11:10

@servimo: Thanks for reporting. To mitigate the conflict error I moved the binary for the python2 version to yowsup-cli2. Bear in mind that you usually dont need both packages though.
However, I could not reproduce your version error. Could you describe how you come to that conclusion?

servimo commented on 2017-10-22 15:20

error: failed to commit transaction (conflicting files)
/ usr / bin / yowsup-cli exists in both "python2-yowsup" and "python-yowsup"
/usr/share/yowsup/common/mime.types exists in both "python2-yowsup" and "python-yowsup"
Errors occurred, so no packages were updated.

servimo commented on 2017-10-22 14:20

compiling only works if I edit deleting in pkgbuild python-yowsup, but keeps version as 2.5.0

je-vv commented on 2016-08-13 04:57

No problem, I didn't know it gets installed if installing python2-yowsup... So it's fine... Perhaps you should have a note NOT to install it directly, :-) I'm glad I can get it...