Package Details: python2-apt 1.1.0~beta2-1

Git Clone URL: (read-only)
Package Base: python-apt
Description: Python binding of libapt-pkg
Upstream URL:
Licenses: GPL2
Submitter: JonnyJD
Maintainer: JonnyJD (HaaTa)
Last Packager: HaaTa
Votes: 2
Popularity: 0.000000
First Submitted: 2014-06-11 08:37
Last Updated: 2016-04-01 19:50

Required by (5)

Sources (2)

Latest Comments

HaaTa commented on 2016-04-01 19:53

@JonnyJD: Cool, just updated the pkg. Made sure to update the minimum apt version as well.

JonnyJD commented on 2016-04-01 19:10

@HaaTa: I added you. If the beta fixes things you can just update the package to that version.

HaaTa commented on 2016-04-01 18:10

I guess I could maintain the package (as I need it for some work related things). Though I'm not sure how often the package will change as Ubuntu currently uses the beta in their stable release.
Also, I'm not sure I can guarantee the python2 package will be working as I won't be using it.

JonnyJD commented on 2016-03-30 06:29

In case we have to run beta in order to work with recent apt:
anybody willing to maintain this then?
With me the package would be constantly out of date I guess.

JonnyJD commented on 2016-03-30 06:11

hm, possibly a problem with an apt version that is "too new" (I am running ATM).
I might have time to check this with updated apt later today.

HaaTa commented on 2016-03-30 01:03

I'm getting compiler errors with The beta doesn't have these issues.

ython/apt_pkgmodule.h:193:34: error: 'indexRecords' was not declared in this scope
PyObject* PyIndexRecords_FromCpp(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/apt_pkgmodule.h:193:48: error: expected primary-expression before 'const'
PyObject* PyIndexRecords_FromCpp(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/apt_pkgmodule.h:193:60: error: expected primary-expression before 'bool'
PyObject* PyIndexRecords_FromCpp(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/apt_pkgmodule.h:193:82: error: expected primary-expression before '*' token
PyObject* PyIndexRecords_FromCpp(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/apt_pkgmodule.h:193:83: error: 'Owner' was not declared in this scope
PyObject* PyIndexRecords_FromCpp(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/apt_pkgmodule.h:193:88: error: expression list treated as compound expression in initializer [-fpermissive]
PyObject* PyIndexRecords_FromCpp(indexRecords* const &obj, bool Delete, PyObject *Owner);
In file included from python/apt_pkgmodule.h:211:0,
from python/
python/python-apt.h:111:37: error: expected ';' at end of member declaration
PyObject* (*indexrecords_fromcpp)(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/python-apt.h:111:51: error: expected ')' before '*' token
PyObject* (*indexrecords_fromcpp)(indexRecords* const &obj, bool Delete, PyObject *Owner);
python/python-apt.h:112:5: error: 'indexRecords' does not name a type
indexRecords*& (*indexrecords_tocpp)(PyObject *self);

JonnyJD commented on 2016-03-29 05:28

Thanks, I use the from jessie.
The beta version is in preparation for stretch and will change rapidly (and possibly break).

HaaTa commented on 2016-03-29 01:23

Versioning seems to have changed. seems to be the latest stable version.

JonnyJD commented on 2015-02-12 11:36

I prepared a split package for the Python 2 and 3 version.
Before I can upload there will be a short time between the merge of python2-apt into python-apt and me uploading the split package to AUR.
You can get the split package build here already:

JonnyJD commented on 2015-02-12 01:21

Or rather, I only updated the python 3 version..

JonnyJD commented on 2015-02-12 01:20

Oh, I updated the package a week ago in the repository, but forgot to upload it to AUR :-/

tofubanditx commented on 2015-02-11 19:47

python-apt_0.9.3.8.tar.xz does not exist anymore. I had it fetch and install python-apt_0.9.3.11.tar.xz instead, and so far so good.

JonnyJD commented on 2015-02-04 23:28

I updated the package to the latest version.

While most python modules are architecture independent, some include compiled code, which is the case here.
$ file /usr/lib/python*/site-packages/apt_*.so

These are not architecture independent and part of python*-apt.

eomarjee commented on 2015-02-03 13:52

Please change to arch=('any')

JonnyJD commented on 2014-06-11 08:40

The distutils-extra makedep is not necessarily needed, but it builds the locales so I re-added it.
The apt problem seems to be due to me making changes while compiling so I updated to now.

I created

JonnyJD commented on 2014-06-11 07:41

I updated to for now. This also removes python2-distutils-extra and python2-debian as makedeps. needs apt 1.0.4, which again seems to need other updates/fixes.
I'll fix that later on, hopefully today.

From the changelog it sounds like Python 3 support was added. I'll add another package after I fixed the rest; unless somebody else creates it ;-)

saturn_knight commented on 2014-06-11 04:20

python-apt_0.9.1.tar.gz is no longer available.
Updating to python-apt_0.9.3.6 with md5sum adade1c69bd21c9741194d9f3cb387cb works.
python_apt_0.9.3.7 is also available for download but fails to compile.

piquer commented on 2013-11-14 09:07

python-apt_0.8.9.1.tar.gz is not available anymore on the debian ftp. Using 0.9.1 with md5sum 2b59d6f4b06bdaaa14c52fd5f9a19f9a works.