Package Details: python2-argparse 1.4.0-2

Git Clone URL: (read-only)
Package Base: python-argparse
Description: Python2 command-line parsing library
Upstream URL:
Licenses: custom
Submitter: mawcomw
Maintainer: mawcomw
Last Packager: mawcomw
Votes: 44
Popularity: 4.402742
First Submitted: 2014-08-03 01:12
Last Updated: 2015-10-31 21:17

Latest Comments

the_lf commented on 2016-08-26 04:33

*Please* remove python-setuptools dependency, it is certifiably pointless.

bcc commented on 2015-10-05 07:43

version 1.4.0 is out

ice9 commented on 2015-03-23 23:31

After building the package, when I try to install it with pacman, I get the errors below. Any idea what is wrong?

error: failed to commit transaction (conflicting files)
/usr/lib/python2.7/site-packages/argparse-1.3.0-py2.7.egg-info/PKG-INFO exists in both 'python-argparse' and 'python2-argparse'
/usr/lib/python2.7/site-packages/argparse-1.3.0-py2.7.egg-info/SOURCES.txt exists in both 'python-argparse' and 'python2-argparse'
/usr/lib/python2.7/site-packages/argparse-1.3.0-py2.7.egg-info/dependency_links.txt exists in both 'python-argparse' and 'python2-argparse'
/usr/lib/python2.7/site-packages/argparse-1.3.0-py2.7.egg-info/top_level.txt exists in both 'python-argparse' and 'python2-argparse'
/usr/lib/python2.7/site-packages/ exists in both 'python-argparse' and 'python2-argparse'
/usr/lib/python2.7/site-packages/argparse.pyc exists in both 'python-argparse' and 'python2-argparse'
/usr/lib/python2.7/site-packages/argparse.pyo exists in both 'python-argparse' and 'python2-argparse'

mawcomw commented on 2015-03-06 00:34

Changed arch to any as requested.

hcartiaux commented on 2015-03-02 13:55

Please, consider the last comment sent by :) commented on 2015-01-26 15:19

Please change this in the PKGBUILD:
arch=('any') commented on 2015-01-26 15:17

Please edit following in the PKGBUILD:


metalgamer commented on 2014-12-18 09:50

The development is done on pypi now and the new packages are also on pypi. Here is an updated PKGBUILD:

sn6uv commented on 2014-12-04 10:44

As it is currently packaged this package additionally requires python2-setuptools and python-setuptools

lb.laboon commented on 2014-11-26 15:03

Why shouldn't python-setuptools be a make dependency? I can't build this package unless python-setuptools is installed.

All comments