Package Details: python2-buildozer 0.32-1

Git Clone URL: https://aur.archlinux.org/python2-buildozer.git (read-only)
Package Base: python2-buildozer
Description: Generic Python packager for Android / iOS and Desktop
Upstream URL: https://github.com/kivy/buildozer
Licenses: MIT
Conflicts: buildozer
Provides: buildozer, python2-buildozer
Submitter: atweiden
Maintainer: None
Last Packager: atweiden
Votes: 3
Popularity: 0.000000
First Submitted: 2013-12-27 08:24
Last Updated: 2016-05-09 16:16

Latest Comments

AwesomeHaircut commented on 2017-05-05 01:11

Is there any particular reason you use this package instead of pip @paulsinnett ?
I could fix the dependencies if this is useful to you.

paulsinnett commented on 2017-04-28 23:11

Also needs hostpython2 added to the requirements entry in the auto generated buildozer.spec file as described in this bug:
https://github.com/kivy/python-for-android/issues/620#issuecomment-186167468

paulsinnett commented on 2017-04-28 19:19

Okay, it had python2-colorama installed, but it needed python-colorama.

Also, python-sh and python-jinja.

paulsinnett commented on 2017-04-28 18:52

There may be some dependency issues here. I just installed this on a fresh machine and got:

ERROR: The colorama Python module could not be found, please install version 0.3.3 or higher
ERROR: The sh Python module could not be found, please install version 1.10 or higher
ERROR: The jinja2 Python module could not be found, please install it.
python-for-android is exiting due to the errors above.
# Command failed: python -m pythonforandroid.toolchain --color=always --storage-dir=/home/paul/Documents/MyApps/.buildozer/android/platform/build create --dist_name=clicker --bootstrap=sdl2 --requirements=kivy --arch armeabi-v7a --copy-libs
#
# Buildozer failed to execute the last command
# The error might be hidden in the log above this error
# Please read the full log, and search for it before
# raising an issue with buildozer itself.
# In case of a bug report, please add a full log with log_level = 2

Oddly, the colorama module is installed, but it's still complaining.