Package Details: python2-catkin-tools 0.4.4-2

Git Clone URL: https://aur.archlinux.org/python2-catkin-tools.git (read-only)
Package Base: python2-catkin-tools
Description: Command line tools for working with catkin
Upstream URL: https://github.com/catkin/catkin_tools
Licenses: Apache
Submitter: v01d
Maintainer: wbthomason
Last Packager: wbthomason
Votes: 1
Popularity: 0.000025
First Submitted: 2015-12-13 02:03
Last Updated: 2017-06-01 20:59

Latest Comments

racko commented on 2017-08-12 21:26

Hi,

catkin-tools is not fully compatible with make versions >= 4.2 (arch uses 4.2.1) because of the backward-incompatibility mentioned in https://lists.gnu.org/archive/html/info-gnu/2016-05/msg00013.html.

I created a patch: https://gist.github.com/racko/dab16d5313927065dafe83d08f975243

If anybody sees warnings like "Make job server not supported. The number of Make jobs may exceed the number of CPU cores." or "warning: -jN forced in submake: disabling jobserver mode.", this is for you.

I will see if I can get this simple patch accepted upstream or if they need to support older make versions ...

wbthomason commented on 2017-06-01 20:59

@kartikmohta: Done.

kartikmohta commented on 2017-06-01 20:27

Can you please change the dependency of python2-osrf-pycommon to python2-osrf_pycommon. I've asked for a deletion of the old package from AUR and would be maintaining it under the new name.

wbthomason commented on 2017-05-08 22:18

Adopted package to update to 0.4.4.

v01d commented on 2017-01-05 22:24

i'm disowning package, no longer using it. feel free to adopt.

v01d commented on 2015-12-17 20:37

done

korken89 commented on 2015-12-17 17:00

Hi, this package has a missing dependency on python2-yaml.

Best // Emil