Package Details: python2-click-5.1 5.1-3

Git Clone URL: https://aur.archlinux.org/python-click-5.1.git (read-only)
Package Base: python-click-5.1
Description: A simple wrapper around optparse for powerful command line utilities
Upstream URL: http://click.pocoo.org/
Keywords: api cli creation interface kit python
Licenses: BSD
Conflicts: python2-click
Provides: python2-click
Submitter: bricewge
Maintainer: ginkel (GPereira)
Last Packager: GPereira
Votes: 17
Popularity: 0.354394
First Submitted: 2016-01-09 17:40
Last Updated: 2018-04-15 14:08

Dependencies (1)

Required by (41)

Sources (1)

Latest Comments

ginkel commented on 2018-04-11 19:18

@GPereira: Sure! Sorry for the delayed reply.

GPereira commented on 2018-04-02 18:00

Yes it misses python2-setuptool as a dependency. Can I comantain this package with you? :)

Geend commented on 2018-01-10 12:56

This seems to depend on python2-setuptool to install.

ginkel commented on 2017-11-16 22:59

The recent change of building python-click-6.7 unfortunately breaks a couple of depending packages, such as platformio. Would be great if you could restore python-click-5.1.

Thanks!

jazzpi commented on 2017-11-15 20:18

This is impossible to install again because the PKGBUILD actually provides python-click-6.7.

To install it now, clone the git repository, checkout HEAD^ and run makepkg.

bricewge commented on 2016-09-15 23:16

Thanks you for pointing this out. It should be fixed now.

Jake commented on 2016-09-15 12:27

This is impossible to install because it will generate 2 packages that conflict each other. You should move the corrensponding conflict/provides into the package():

package_python-click-5.1() {
depends=("python")
provides=("python-click")
conflicts=("python-click")
... }