Package Details: python2-django-rest-framework 3.9.4-1

Git Clone URL: https://aur.archlinux.org/python2-django-rest-framework.git (read-only, click to copy)
Package Base: python2-django-rest-framework
Description: Awesome web-browsable Web APIs
Upstream URL: https://github.com/tomchristie/django-rest-framework
Licenses: MIT
Submitter: fryfrog
Maintainer: fryfrog
Last Packager: fryfrog
Votes: 0
Popularity: 0.000000
First Submitted: 2019-07-23 21:03
Last Updated: 2019-11-30 15:16

Dependencies (6)

Sources (1)

Latest Comments

fryfrog commented on 2019-11-30 15:18

Oops, I forgot it couldn't be updated! Reverted, sorry!

mqs commented on 2019-11-30 11:10

The package won't build:

==> Making package: python2-django-rest-framework 3.10.3-1 (Sat Nov 30 12:06:23 2019)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found djangorestframework-3.10.3.tar.gz
==> Validating source files with sha512sums...
    djangorestframework-3.10.3.tar.gz ... Passed
==> Extracting sources...
  -> Extracting djangorestframework-3.10.3.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...

==========================
Unsupported Python version
==========================

This version of Django REST Framework requires Python 3.5, but you're trying
to install it on Python 2.7.

This may be because you are using a version of pip that doesn't
understand the python_requires classifier. Make sure you
have pip >= 9.0 and setuptools >= 24.2, then try again:

    $ python -m pip install --upgrade pip setuptools
    $ python -m pip install djangorestframework

This will install the latest version of Django REST Framework which works on
your version of Python. If you can't upgrade your pip (or Python), request
an older version of Django REST Framework:

    $ python -m pip install "django<3.10"
==> ERROR: A failure occurred in package().
    Aborting...

have I missed something? The rest of my system is up2date.