Package Details: python2-efl-git 1.14.99a936.g37930f3-1

Git Clone URL: https://aur.archlinux.org/python2-efl-git.git (read-only)
Package Base: python2-efl-git
Description: Python2 bindings for the Enlightenment Foundation Libraries - Development Version
Upstream URL: http://www.enlightenment.org
Licenses: GPL3, LGPL3
Conflicts: python2-efl
Provides: python2-efl=1.14.99a936.g37930f3
Submitter: Scimmia
Maintainer: None
Last Packager: Scimmia
Votes: 15
Popularity: 0.000000
First Submitted: 2013-03-23 00:49
Last Updated: 2016-11-05 16:09

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Changaco commented on 2012-10-24 11:27

I still have a copy of my version (the license field was correct), as you can see it was submitted 2 years ago, since then both the code upstream and the packaging standards of Arch have evolved, it doesn't mean my version is a mess, it just means it's old, so thanks for updating.

Scimmia commented on 2012-10-24 11:10

Changaco, I'm sorry, removing the names was a mistake. I didn't have them in when I was redoing things as I was using a single template for multiple E17 python2 binding PKGBUILDs and must have forgotten to add them back in to this package. This has been corrected.

As for the python2 binding packages being a mess; no package section, exporting an environmental variable, incorrect dependencies, incorrect licenses, not making a copy of the svn dir before building, etc. Yes, I will say the were a mess. I started from scratch with a template from the Wiki.

Changaco commented on 2012-10-24 09:56

Changing a few things and moving lines around is not "completely redoing it". I suggest you stay polite with previous contributors and don't remove their names from the PKGBUILD.

Scimmia commented on 2012-10-24 09:11

Being a python2 package, the name should be python2-elementary-svn. There is already a package with that name, which I updated to actually work right so I could make a working pkgbuild for econnman. If you want to keep this as python2, the cython makedep should atleast be changed to cython2.

Scimmia commented on 2012-10-24 06:27

OK, this package should work now. The original was a mess, I threw it out and completely redid it.

Scimmia commented on 2012-10-24 05:35

Makedep cython should be changed to cython2

bartbes commented on 2012-05-18 10:31

Thanks, fixed.

Anonymous comment on 2012-05-17 11:03

this package should have cython2 instead of cython in its makedepends. The patch doesnt seem to required anymore, patch complains about reverse patch

splippity commented on 2011-12-31 06:26

package doesnt work could you update it?? fails with:

sed: no input files
==> ERROR: A failure occurred in build().
Aborting...

abarbarian commented on 2011-05-02 19:04

Many thanks it now installs.