Package Details: python2-elixir 0.7.1-6

Git Clone URL: https://aur.archlinux.org/python2-elixir.git (read-only)
Package Base: python2-elixir
Description: Declarative mapper for SQLAlchemy
Upstream URL: http://elixir.ematia.de/apidocs/elixir.html
Licenses: MIT
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 37
Popularity: 0.000000
First Submitted: 2013-07-17 10:14
Last Updated: 2018-05-24 18:29

Latest Comments

willemw commented on 2018-04-19 20:33

@AxelTrance: Should be fixed.

AxelTrance commented on 2018-04-19 18:55

==> python2-elixir dependencies: - python2-sqlalchemy>=0.7.9 (already installed) - python2-setuptools (already installed) [makedepend] - python2-sqlalchemy<0.8 (building from AUR)

==> Continue building python2-elixir ? [Y/n] ==> ---------------------------------------- ==>

==> Building and installing package ==> Install or build missing dependencies for python2-elixir: [sudo] password for axelt: error: target not found: python2-sqlalchemy<0.8 ==> Restart building python2-elixir ? [y/N]

then i restart building and edited PKGBUILD. Have to mod this line:

depends=('python2-sqlalchemy>=0.7.9' 'python2-sqlalchemy<0.8')

to this:

depends=('python2-sqlalchemy')

willemw commented on 2018-04-19 17:42

@AxelTrance: What's the issue? Is it a packaging issue? It builds just fine for me.

AxelTrance commented on 2018-04-19 16:07

have to edit PKGBUILD to fix an error in requester sqlalchemy name

willemw commented on 2013-07-17 10:15

Renamed package python2-elixir is now available.

rpodgorny commented on 2012-07-27 09:18

...since this is a python2 module, shouldn't it be renamed to python2-elixir?

Anonymous comment on 2011-08-10 07:41

@malte70:thx:)

malte70 commented on 2011-08-06 12:15

@stuarch: The PKGBUILD is missing the python2-distribute dependency.

Anonymous comment on 2011-08-05 09:21

Sorry
I install it with yaourt
but an error occur like this :

==> Continue building python-elixir ? [Y/n]
==>
==>
==> Building and installing package
==> WARNING: Building package as root is dangerous.
Please run yaourt as a non-privileged user.
==> Making package: python-elixir 0.7.1-4 (五 8月 5 17:18:23 CST 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found Elixir-0.7.1.tar.gz
==> Validating source files with md5sums...
Elixir-0.7.1.tar.gz ... Passed
==> Extracting Sources...
-> Extracting Elixir-0.7.1.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Starting build()...
==> Starting package()...
Traceback (most recent call last):
File "setup.py", line 1, in <module>
from setuptools import setup, find_packages
ImportError: No module named setuptools
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build python-elixir.
==> Restart building python-elixir ? [y/N]
==>
==>
==> WARNING: Following packages have not been installed:
python-elixir

cmb commented on 2011-07-30 12:42

Someone flagged this as out-of-date, but the latest official version
is still 0.7.1.
Unflagging.

All comments