Package Details: python2-eventlet-git 0.20.0+6+ge1bb2fe-1

Git Clone URL: https://aur.archlinux.org/python-eventlet-git.git (read-only)
Package Base: python-eventlet-git
Description: Highly concurrent networking library
Upstream URL: http://eventlet.net
Licenses: MIT
Conflicts: python2-eventlet
Provides: python2-eventlet
Submitter: anthraxx
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 0
Popularity: 0.000000
First Submitted: 2016-12-22 23:35
Last Updated: 2016-12-22 23:35

Dependencies (30)

Required by (36)

Sources (1)

Latest Comments

xiretza commented on 2018-08-25 16:18

Also, tests are failing with python3.7, see upstream report: https://github.com/eventlet/eventlet/issues/502

xiretza commented on 2018-08-25 15:57

apparently this needs a non-optional makedepends=('python-dnspython' 'python-monotonic'), otherwise the build fails while generating docs:

make: Entering directory '/build/python-eventlet-git/src/python-eventlet-git/doc'
PYTHONPATH=../: sphinx-build -b text -d _build/doctrees   . _build/text
Running Sphinx v1.7.6

Configuration error:
There is a programable error in your configuration file:

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/sphinx/config.py", line 161, in __init__
    execfile_(filename, config)
  File "/usr/lib/python3.7/site-packages/sphinx/util/pycompat.py", line 150, in execfile_
    exec_(code, _globals)
  File "conf.py", line 52, in <module>
    import eventlet
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/__init__.py", line 10, in <module>
    from eventlet import convenience
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/convenience.py", line 7, in <module>
    from eventlet.green import socket
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/green/socket.py", line 21, in <module>
    from eventlet.support import greendns
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/support/greendns.py", line 62, in <module>
    dns = import_patched('dns')
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/support/greendns.py", line 59, in import_patched
    return patcher.import_patched(module_name, **modules)
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/patcher.py", line 120, in import_patched
    *additional_modules + tuple(kw_additional_modules.items()))
  File "/build/python-eventlet-git/src/python-eventlet-git/eventlet/patcher.py", line 94, in inject
    module = __import__(module_name, {}, {}, module_name.split('.')[:-1])
ModuleNotFoundError: No module named 'dns'

make: *** [Makefile:35: text] Error 2
make: Leaving directory '/build/python-eventlet-git/src/python-eventlet-git/doc'
==> ERROR: A failure occurred in build().

The same with 'monotonic'.

juanrubio commented on 2018-04-24 20:14

anthraxx: you're absolutely right, I had a link python -> python2. Thanks!

anthraxx commented on 2018-04-24 17:03

juanrubio: happens when you make python be python2, either you overwrote something or using virtualenv. won't fix and works in a clean environment.

juanrubio commented on 2018-04-24 16:10

Hi,

I'm still experiencing problems while doing:

yaourt -S python2-eventlet-git

.... after a while, I get this .... looking for conflicting packages...

Packages (2) python-eventlet-git-0.22.1+8+g69983c6d-1 python2-eventlet-git-0.22.1+8+g69983c6d-1

Total Installed Size: 6.82 MiB

:: Proceed with installation? [Y/n] y (2/2) checking keys in keyring [####################################################################] 100% (2/2) checking package integrity [####################################################################] 100% (2/2) loading package files [####################################################################] 100% (2/2) checking for file conflicts [####################################################################] 100% error: failed to commit transaction (conflicting files) /usr/lib/python2.7/site-packages/eventlet-0.22.1-py2.7.egg-info/PKG-INFO exists in both 'python2-eventlet-git' and 'python-eventlet-git' /usr/lib/python2.7/site-packages/eventlet-0.22.1-py2.7.egg-info/SOURCES.txt exists in both 'python2-eventlet-git' and 'python-eventlet-git' /usr/lib/python2.7/site-packages/eventlet-0.22.1-py2.7.egg-info/dependency_links.txt exists in both 'python2-eventlet-git' and 'python-eventlet-git' /usr/lib/python2.7/site-packages/eventlet-0.22.1-py2.7.egg-info/not-zip-safe exists in both 'python2-eventlet-git' and 'python-eventlet-git' /usr/lib/python2.7/site-packages/eventlet-0.22.1-py2.7.egg-info/requires.txt exists in both 'python2-eventlet-git' and 'python-eventlet-git' /usr/lib/python2.7/site-packages/eventlet-0.22.1-py2.7.egg-info/top_level.txt exists in both 'python2-eventlet-git' and 'python-eventlet-git'

anthraxx commented on 2018-03-13 10:27

update your system, there was a fix to pyopenssl yesterday

juanrubio commented on 2018-03-13 09:23

My app (https://github.com/tizonia/tizonia-openmax-il) has a dependency on eventlet.

I'm currently getting this error installing python2-evently-git, is there a way to get this fixed or workaround somehow? Thanks!

====================================================================== ERROR: tests.openssl_test.test_import

<hr>

Traceback (most recent call last): File "/usr/lib/python3.6/site-packages/nose/case.py", line 197, in runTest self.test(self.arg) File "/tmp/yaourt-tmp-joni/aur-python2-eventlet-git/src/python-eventlet-git/tests/openssl_test.py", line 13, in test_import import eventlet.green.OpenSSL.SSL File "/tmp/yaourt-tmp-joni/aur-python2-eventlet-git/src/python-eventlet-git/eventlet/green/OpenSSL/init.py", line 2, in <module> from . import SSL File "/tmp/yaourt-tmp-joni/aur-python2-eventlet-git/src/python-eventlet-git/eventlet/green/OpenSSL/SSL.py", line 2, in <module> from OpenSSL.SSL import </module></module> File "/usr/lib/python3.6/site-packages/cryptography/utils.py", line 124, in getattr obj = getattr(self._module, attr) AttributeError: module 'OpenSSL.SSL' has no attribute 'SSL_ST_INIT'

<hr>

Ran 671 tests in 59.545s

FAILED (SKIP=95, errors=1) ==> ERROR: A failure occurred in check(). Aborting... ==> ERROR: Makepkg was unable to build python-eventlet-git.