Package Details: python2-flask-compress 1.4.0-1

Git Clone URL: https://aur.archlinux.org/python2-flask-compress.git (read-only)
Package Base: python2-flask-compress
Description: compress responses in your Flask app with gzip
Upstream URL: http://pypi.python.org/pypi/Flask-Compress/
Licenses: BSD
Submitter: cgirard
Maintainer: cgirard
Last Packager: cgirard
Votes: 10
Popularity: 0.273298
First Submitted: 2015-10-09 12:45
Last Updated: 2017-08-23 14:19

Latest Comments

vith commented on 2018-09-18 15:42

I think you need to pull the makedepends out of the package functions. At least yay is not picking them up there.

==> Starting package_python2-flask-compress()...
Traceback (most recent call last):
  File "./setup.py", line 1, in <module>
    import setuptools
ImportError: No module named setuptools
==> ERROR: A failure occurred in package_python2-flask-compress().
    Aborting...
Error making: python2-flask-compress (python-flask-compress)

namcap seems to agree:

PKGBUILD (python2-flask-compress) E: Split PKGBUILD needs additional makedepends ['python-flask', 'python-setuptools', 'python2-flask', 'python2-setuptools'] to work properly

cgirard commented on 2017-08-23 14:19

done

thrasibule commented on 2017-07-11 14:18

Could you change it to generate both python2 and python3 packages? Also the description doesn't look right.

Anonymous comment on 2016-09-01 04:13

Please change dependency to python2-setuptools!