Package Details: python2-gnomekeyring 2.32.0-19

Git Clone URL: https://aur.archlinux.org/gnome-python-desktop.git (read-only)
Package Base: gnome-python-desktop
Description: Python bindings for libgnome-keyring
Upstream URL: https://www.gnome.org
Licenses: GPL, LGPL
Conflicts: python-gnomekeyring<=2.32.0-10
Replaces: python-gnomekeyring<=2.32.0-10
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 4
Popularity: 2.406838
First Submitted: 2019-06-23 01:34
Last Updated: 2019-06-23 01:34

Latest Comments

1 2 Next › Last »

JohnRobson commented on 2019-08-10 14:20

evo-ecal-environment.c:54:29: error: unknown type name ‘ESourceList’; did you mean ‘ESourceLDAP’?
   54 | evo_environment_find_source(ESourceList *list, const char *uri)
      |                             ^~~~~~~~~~~
      |                             ESourceLDAP
evo-calendar.c: In function ‘evo_cal_component_set_modified’:
evo-calendar.c:242:10: warning: implicit declaration of function ‘icaltime_from_timet’; did you mean ‘icaltime_as_timet’? [-Wimplicit-function-declaration]
  242 |     tt = icaltime_from_timet(seconds, TRUE);
      |          ^~~~~~~~~~~~~~~~~~~
      |          icaltime_as_timet
evo-calendar.c:242:10: error: incompatible types when assigning to type ‘struct icaltimetype’ from type ‘int’
make[2]: *** [Makefile:503: ecal_la-evo-ecal-environment.lo] Error 1
make[2]: *** [Makefile:510: ecal_la-evo-calendar.lo] Error 1
make[2]: Leaving directory '/tmp/yay/gnome-python-desktop/src/gnome-python-desktop-2.32.0/evolution'
make[1]: *** [Makefile:511: all-recursive] Error 1
make[1]: Leaving directory '/tmp/yay/gnome-python-desktop/src/gnome-python-desktop-2.32.0'
make: *** [Makefile:380: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Error making: gnome-python-desktop (python2-wnck)

jm09 commented on 2019-07-19 18:47

@Striffly I edited that file, but its get overwritten the next time I run pacaur -Su

petervrs commented on 2019-07-17 08:34

@Striffly Great that worked! Thank you!

Striffly commented on 2019-07-16 09:06

@petervrs @jm09, edit your PKGBUILD file like this :

PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-metacity --disable-evolution --disable-evolution_ecal

petervrs commented on 2019-07-15 14:38

Would like to know too where --disable-evolution --disable-evolution_ecal should be configured.

jm09 commented on 2019-07-14 16:28

where exactly do you add?

--disable-evolution --disable-evolution_ecal

dbIsMe commented on 2019-07-08 00:19

I had a slightly different error to those mentioned below

evo-calendar.c:242:10: warning: implicit declaration of function ‘icaltime_from_timet’; did you mean ‘icaltime_as_timet’? [-Wimplicit-function-declaration]
  242 |     tt = icaltime_from_timet(seconds, TRUE);
      |          ^~~~~~~~~~~~~~~~~~~
      |          icaltime_as_timet
evo-calendar.c:242:10: error: incompatible types when assigning to type ‘struct icaltimetype’ from type ‘int’
make[2]: *** [Makefile:510: ecal_la-evo-calendar.lo] Error 1
make[2]: Leaving directory '/tmp/pamac-build/gnome-python-desktop/src/gnome-python-desktop-2.32.0/evolution'
make[1]: *** [Makefile:511: all-recursive] Error 1
make[1]: Leaving directory '/tmp/pamac-build/gnome-python-desktop/src/gnome-python-desktop-2.32.0'
make: *** [Makefile:380: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

but editing the build file and adding the --disable-evolution --disable-evolution_ecal on the configure line also worked fine.

The failure had been going on for a couple of weeks, so thanks for the help!

P1tt187 commented on 2019-07-06 00:58

works with

--disable-evolution --disable-evolution_ecal

timhs commented on 2019-06-30 18:43

@entidi thank you! Now with your --disable-evolution --disable-evolution_eca update works

P1tt187 commented on 2019-06-30 12:56

*****************************************************************************
*** WARNING: You are using a deprecated build system (autotools).
***          You should be using WAF instead; see the file INSTALL.WAF.
***          The autotools build system will be removed in a future version.
*****************************************************************************