Package Details: python2-gobject 3.36.1-5

Git Clone URL: https://aur.archlinux.org/python2-gobject.git (read-only, click to copy)
Package Base: python2-gobject
Description: Python 2 Bindings for GLib/GObject/GIO/GTK+
Upstream URL: https://wiki.gnome.org/Projects/PyGObject
Licenses: LGPL
Submitter: Archange
Maintainer: ImperatorStorm
Last Packager: Archange
Votes: 5
Popularity: 0.138515
First Submitted: 2022-05-15 08:52 (UTC)
Last Updated: 2022-05-15 08:52 (UTC)

Latest Comments

khvalera commented on 2022-07-14 21:21 (UTC)

[41/56] Linking target gi/_gi.so FAILED: gi/_gi.so cc -o gi/_gi.so gi/_gi.so.p/pygboxed.c.o gi/_gi.so.p/pygenum.c.o gi/_gi.so.p/pygflags.c.o gi/_gi.so.p/pyginterface.c.o gi/_gi.so.p/pygobject-object.c.o gi/_gi.so.p/pygparamspec.c.o gi/_gi.so.p/pygpointer.c.o gi/_gi.so.p/pygoptioncontext.c.o gi/_gi.so.p/pygoptiongroup.c.o gi/_gi.so.p/pygspawn.c.o gi/_gi.so.p/gimodule.c.o gi/_gi.so.p/pygi-repository.c.o gi/_gi.so.p/pygi-info.c.o gi/_gi.so.p/pygi-foreign.c.o gi/_gi.so.p/pygi-struct.c.o gi/_gi.so.p/pygi-source.c.o gi/_gi.so.p/pygi-argument.c.o gi/_gi.so.p/pygi-resulttuple.c.o gi/_gi.so.p/pygi-type.c.o gi/_gi.so.p/pygi-boxed.c.o gi/_gi.so.p/pygi-closure.c.o gi/_gi.so.p/pygi-ccallback.c.o gi/_gi.so.p/pygi-util.c.o gi/_gi.so.p/pygi-property.c.o gi/_gi.so.p/pygi-signal-closure.c.o gi/_gi.so.p/pygi-invoke.c.o gi/_gi.so.p/pygi-cache.c.o gi/_gi.so.p/pygi-marshal-cleanup.c.o gi/_gi.so.p/pygi-basictype.c.o gi/_gi.so.p/pygi-list.c.o gi/_gi.so.p/pygi-array.c.o gi/_gi.so.p/pygi-error.c.o gi/_gi.so.p/pygi-object.c.o gi/_gi.so.p/pygi-value.c.o gi/_gi.so.p/pygi-enum-marshal.c.o gi/_gi.so.p/pygi-struct-marshal.c.o gi/_gi.so.p/pygi-hashtable.c.o -flto -Wl,--as-needed -Wl,--allow-shlib-undefined -shared -fPIC -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -Wl,--start-group /usr/lib/libglib-2.0.so /usr/lib/libgirepository-1.0.so /usr/lib/libgobject-2.0.so /usr/lib/libffi.so -Wl,--end-group <built-in>: Internal Compiler Error: Bus Error 0x183a2b4 internal_error(char const, ...) ???:0 0x65e0bb decl_attributes(tree_node, tree_node, int, tree_node*) ???:0 Please submit a full bug report, with preprocessed source (by using -freport-bug).

filipg commented on 2022-07-09 07:29 (UTC)

I thought it's out-of-date, but actually the version 3.38.0 won't compile under Python 2.